How to turn off / disable quicklook

Discussion in 'Mac Basics and Help' started by uvsj, Dec 8, 2010.

  1. uvsj macrumors newbie

    Joined:
    Dec 8, 2010
    #1
    Just got a new imac with 10.6. Our folder system has a lot of folders that the name starts with a space. To get around I used to just start typing the name of the folder starting with a space instead of scrolling through our long file list. Not the best system but we have thousands of folders with linked files and we are not going to change the names. Is there a way to turn off or disable quicklook so that I can use the space bar then type to find the folder?
     
  2. Darth.Titan macrumors 68030

    Darth.Titan

    Joined:
    Oct 31, 2007
    Location:
    Austin, TX
    #2
    As far as I know it's not possible to disable Quicklook.

    As a suggestion, you might try using command-space instead and typing your folder name into Spotlight. I know that's not exactly what you want, but it should work OK.
     
  3. John T macrumors 68020

    John T

    Joined:
    Mar 18, 2006
    Location:
    UK.
    #3
    Right click on the Quicklook ikon. Go to "Customize Keyboard" and drag iKon.
     
  4. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
  5. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #5
    This one (attached). My right-click menu shows "Customize Toolbar" not "Customize Keyboard."
     

    Attached Files:

  6. John T macrumors 68020

    John T

    Joined:
    Mar 18, 2006
    Location:
    UK.
    #6
    You're right!! What on earth made me type "Keyboard" when it should have been "Toolbar"? :eek: :eek:
     
  7. LPZ macrumors 65816

    Joined:
    Jul 11, 2006
    #7
    Can just command+drag the icon off the Finder toolbar. But this doesn't disable Quick Look.
     
  8. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #8
    Ok, well, that won't disable it. I thought it was a reference to an application icon, not a tool icon. (or is the latter supposed to be "ikon"?)
     
  9. psound macrumors member

    Joined:
    Nov 5, 2007
    #9
    Really bloody annoying that you can't disable this feature.
     
  10. Jagardn macrumors 6502a

    Joined:
    Apr 18, 2011
    #10
    Mac was designed to use Spotlight, it works better in my opinion. Why try to navigate 10 folders deep when you can hit command + space, start typing and your files are right in front of you. You are just used to having things the way they did in another OS, I as a Mac user get pissed when I use my work laptop on windows and it is more difficult to navigate. It's not even that I am used to a Mac, I just started 6 months ago. I used Windows for over 10 years and Linux for 5, to each his own.
     
  11. John T macrumors 68020

    John T

    Joined:
    Mar 18, 2006
    Location:
    UK.
    #11
    Why? :confused: You don't have to use it!
     
  12. Matt-Locke macrumors newbie

    Matt-Locke

    Joined:
    Mar 7, 2018
    #12
    There is a function in Mac OS that previews files so that you can kinda see what a document looks like before you open it.
    With older versions of Office, this function makes Excel think someone has the file open, and subsequently opens the file as read only.
    I have in the past disable this and it lasted for a long time, but the recent updates re-enabled this feature due to it being… updated.
    Well it still doesn’t work, so it needs to be disabled again.

    This is the folder thats messing us up:
    /System/Library/QuickLook/Office.qlgenerator

    Problem is, folders in the location are protected by MacOS so you have to temporarily disable that protection so you can disable the stupid plugin.

    In order to switch off the System Integrity Protection, you firstly need to boot your Mac from the built in recovery partition, to do this follow the steps below;
    • Power off your Mac
    • Press and hold CMD + R on your Mac keyboard
    • From the Utilities menu, select Terminal
    • Copy and paste or type in the following:
    csrutil disable
    reboot

    Then enable root user, and using the terminal, copy these commands one by one:


    su root (type root password)

    Then from any directory, run this command

    mv /System/Library/QuickLook/Office.qlgenerator /System/Library/QuickLook/Office.backup

    Go back in to recovery mode as described above, and re-enable the system protection;

    • Power off your Mac
    • Press and hold CMD + R on your Mac keyboard
    • From the Utilities menu, select Terminal
    • Copy and paste or type in the following:
    csrutil enable
    reboot

    M. Locke
     
  13. anika200 macrumors newbie

    Joined:
    Feb 15, 2018
    Location:
    USA
    #13
    Wow, am I correct a 7yr old thread has been resurrected. Amazing resource.
     
  14. lostinlodos macrumors newbie

    Joined:
    May 29, 2015
    #14
    Yes. For an answer
    Thank you Matt for supplying a solution.
     

Share This Page