How to turn off eye candy in Mountain Lion

Discussion in 'OS X Mountain Lion (10.8)' started by Peter May, Sep 21, 2013.

  1. Peter May macrumors newbie

    Peter May

    Joined:
    Aug 13, 2013
    #1
    Hi!

    I would like to make my iMac perform a bit better so I decided to turn off some of the effects.
    I succesfully managed to disable the genie effect when minimizing a window with the yellow button.
    My problem now is the green button and the effect it produces when the window gets bigger or smaller.
    It gets really glitchy some times and it's quite annoying.
    I couldn't find how to disable that.
    Any help?

    Also are there any other things I can disable to maximize performance?

    Thank you in advance
     
  2. Xe89, Sep 21, 2013
    Last edited: Sep 21, 2013
  3. benwiggy macrumors 68020

    Joined:
    Jun 15, 2012
    #3
    What hardware are you running?

    Normally, I would not expect the window resizing to be "glitchy" or slow on any machine that can run 10.8.
    Unless you've got some very old hardware that can't handle the graphics, then I suspect you may have some other problem.
     
  4. Peter May thread starter macrumors newbie

    Peter May

    Joined:
    Aug 13, 2013
    #4
    Hello Xe89 and thank you for your reply,

    Both links you posted redirect to the Launchpad fading effect.
    I do not use launchpad at all so I don't think it will help me.

    I am mostly interested in disabling the window animations if you could re post the correct link. :)

    I am running an iMac 21.5'' (late 2009).
    Hmm you think I might have a hardware problem?
     
  5. benwiggy macrumors 68020

    Joined:
    Jun 15, 2012
    #5
    A 2009 Mac should be able to handle the normal graphics effects of Finder and OS X with no problem. An older Mac might struggle, but the "cut-off" for installing 10.8 has eliminated a lot of the hardware that wouldn't cope well.

    I don't think it's necessarily a hardware problem: I would first launch Activity Monitor and see whether your CPU is being heavily used or if all your RAM is being used.
    Also, check how much free disk space you have left. You want at least 10% free.

    It might be worth booting to the Recovery Partition, running Disk Utility and Repairing the DISK on your main volume. (NB: DISK, not Permissions, which does nothing.)
     
  6. Peter May thread starter macrumors newbie

    Peter May

    Joined:
    Aug 13, 2013
    #6
    Thank you for your reply benwiggy!

    I have attached screen shots from my Activity Monitor both from the CPU tab and the RAM tab.

    Disk space can't be an issue. My disk has 33GB/500GB used space.
    I tend to keep all my files in external disks.

    What do you mean by "boot to the Recovery Partition"?
    I didn't boot from anywhere. I just went straight to Disk Utility and did "Verify Disk" and then "Repair Disk" and showed that it had no problems at all.
    Are you referring to something else?

    Thank you in advance :)
     

    Attached Files:

    • cpu.png
      cpu.png
      File size:
      270.3 KB
      Views:
      78
    • ram.png
      ram.png
      File size:
      283.8 KB
      Views:
      76
  7. Xe89 macrumors regular

    Joined:
    Oct 23, 2009
    #7
    Sorry, I copied the wrong one. Here is the one about window animations:

    http://osxdaily.com/2011/07/25/disable-the-new-window-animation-in-mac-os-x-lion/

    Note that this is about the animation that occurs when opening new windows, the "zoom effect". I don't know how to disable the resizing animation. Perhaps you could try a third party tool like Divvy, it's both faster and more powerful than using the green circle (since I started using Macs I have actually never used the traffic lights at all).
     
  8. benwiggy macrumors 68020

    Joined:
    Jun 15, 2012
    #8
    Your CPU usage seems quite light: does the slow animation happen all the time, or just when you're busy with lots of apps? (You've got a lot of Chrome stuff going on there. I don't know if that's an issue.)
    Your memory is being fully used and you are using a bit of swap (caching to disk). But not enough to cause this problem all the time.
    If you click on the column headers, you can sort the table by those columns. So sorting by CPU% or Real Memory will be useful in seeing what is using the most.

    As for Recovery Partition. Your hard drive has a hidden partition, called the Recovery Partition, which includes utilities and a reinstaller. You can't Repair the disk that you are currently running the system from (your main internal volume). "Repair Disk" is greyed out in Disk Utility when your Macintosh HD volume is selected. So you must have done something else.
    By rebooting to the RP, you can then repair the disk.
    http://support.apple.com/kb/HT4718
     
  9. gumblecosby, Sep 21, 2013
    Last edited: Sep 21, 2013

    gumblecosby macrumors 6502

    Joined:
    Jun 22, 2010
    #9
    Definitely disable the 3d dock. Your gui will be smoother for it.
    Paste the following command into the Terminal application and press enter.
    The terminal application is located in your "Utilities" folder:

    defaults write com.apple.dock no-glass -boolean YES; killall Dock


    This switches' your dock to the 2d version which helps to smooth things on less powerful computers.
     
  10. benwiggy macrumors 68020

    Joined:
    Jun 15, 2012
    #10
    Another Terminal command is this:

    defaults write NSGlobalDomain NSWindowResizeTime -float 0.001

    which speeds up the time taken to resize windows.
     

Share This Page