how to turn OFF trackpad in Leopard 10.5.6. *TESTED*

Discussion in 'MacBook Pro' started by kemo, Feb 15, 2009.

  1. kemo macrumors 6502a

    kemo

    Joined:
    Oct 29, 2008
    Location:
    /Users/kemo
    #1
    Hello every1!

    This prefPane has been tested on 10.6 (10A394 seed) and all is working fine!

    I was jsut wondering how many of us (Mac users) having problems with 10.5.6 update. As you noticed, there is missing option to disable trackpad if you have your mouse, tablet or other devices do the "work" instead of trackpad, and having trackpad on is a bit annoying, at least for me.

    So I was looking for some good solution, and finally found one. Just opened "new" prefPane, showed up contents of this file and found something really interesting. Apple developers just renamed contents of old prefPane and added new one, so there is nothing easier than just remove the new one, and get back the old one;) Better check screenshots below...

    So, here are screenshots:
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]

    I dont know if it is a good idea to upload my "modded" prefpane...but if you are interested, just contact me via msn,icq or yahoo.

    SO, I decided to upload it.

    Before you download this MODDED prefPane, be sure:
    - you have 10.5.6 update installed.
    - YOU HAVE BACKUP OF YOUR ORIGINAL prefPane file!


    I`m NOT responsible for any difficulties or problems followed with this prefPane, be sure you backup you old prefPane!
    I tried to figure out with this problem and for me it works like charm, so I hope this gonna helps!


    http://rapidshare.com/files/198446463/Trackpad.prefPane_for_10.5.6_by_kemo.zip

    I think there will be premission problem with overiting prefPane file, extract the prefPane file you've downloaded, then open up terminal, and simply copy to your /System/Library/PreferencePanes/ directory this file as Super user... that`s how I did it, restart system open UP system preferences, then go to Trackpad and you should see "old" prefPane like before the 10.5.6 update...
    please, post any problems, better solutions or even critique here...

    Thanks in Advance,

    Tom
     
  2. UltraNEO* macrumors 601

    UltraNEO*

    Joined:
    Jun 16, 2007
    Location:
    近畿日本
    #2
    You can, if you'd like.
    It'll allow other's to test it and report back if needed.
    Just make sure it's labelled as "modded"
     
  3. nikhsub1 macrumors 68000

    nikhsub1

    Joined:
    Jun 19, 2007
    Location:
    mmmm... jessica.'s beer...
    #3
    Umm, I am running 10.5.6 and I have the option to check "Ignore trackpad when mouse if present". I don't get this thread.
     
  4. r.j.s Moderator emeritus

    r.j.s

    Joined:
    Mar 7, 2007
    Location:
    Texas
    #4
    Do you have an new Alu MB or MBP? IIRC, it is not present on those, but it is present on the older ones.
     
  5. drlunanerd macrumors 65816

    drlunanerd

    Joined:
    Feb 14, 2004
    Location:
    UK
    #5
    Is this a bug or a feature in 10.5.6 on only certain Macs?
    I still have the disable trackpad option and I'm running 10.5.6 with no mods.
     
  6. eldy macrumors 6502

    Joined:
    Jan 30, 2009
    Location:
    The City
    #6
    Unibody only.
     
  7. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #7
    Works, but you lose the ability to customize multitouch.
     
  8. kemo thread starter macrumors 6502a

    kemo

    Joined:
    Oct 29, 2008
    Location:
    /Users/kemo
    #8
    Umm

    Ehm, I`ve got the older one, and after update I lost prefpane with ability to disable mouse.. so, Dont know what`s true then..

    // eh my mistake, wanted to say "disable trackpad" ..
     
  9. eldy macrumors 6502

    Joined:
    Jan 30, 2009
    Location:
    The City
    #9
    If you want to disable the mouse, unplug it.
     
  10. kemo thread starter macrumors 6502a

    kemo

    Joined:
    Oct 29, 2008
    Location:
    /Users/kemo
    #10
    You dont understand the point of this topic mate, there is a problem with that, many of Mac users, that updated to 10.5.6 lost ability to "disable" trackpad when the mouse is plugged, and also automatically get it enabled when the mouse is unplugged, I was between them, I just wanna share what Was MINE solution to this problem, cause the option to disable trackpad when the mouse is connected simply dissapeared after update and doesnt worked for me until I made changes mentioned above..
     
  11. procreative macrumors newbie

    Joined:
    Dec 24, 2008
    #11
    I believe apple removed that function because they want users to have multitouch functionality even while using the mouse. I hate it. My cursor accidentally moves every time my palm brushes the trackpad when i got to press a key command in photoshop. Bring it back Apple! PLEEEEEASE!!!!
     
  12. kemo thread starter macrumors 6502a

    kemo

    Joined:
    Oct 29, 2008
    Location:
    /Users/kemo
    #12
    Totally Agree with you mate!
     
  13. drlunanerd macrumors 65816

    drlunanerd

    Joined:
    Feb 14, 2004
    Location:
    UK
    #13
    No, OP isn't using a Unibody.
    I believe this "feature" applies to all multi-touch trackpad MacBook/Pros.
     
  14. eldy macrumors 6502

    Joined:
    Jan 30, 2009
    Location:
    The City
    #14
    There's multitouch on non Unibody MBs? Wow. I thought that... Wow.
     
  15. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #15
    Yes since January 2008.
     
  16. drlunanerd macrumors 65816

    drlunanerd

    Joined:
    Feb 14, 2004
    Location:
    UK
    #16
    You gettin' fresh with me bro? :cool: ;)
     
  17. eldy macrumors 6502

    Joined:
    Jan 30, 2009
    Location:
    The City
    #17
    Let's have a bro drink at the Manhole. Do some shots bro. We can go to Backdoor Liquors afterwards and grab a nice Shiraz. :cool: ;)
     
  18. Bronzit macrumors newbie

    Bronzit

    Joined:
    Mar 23, 2009
    Location:
    Escondido, CA, USA
    #18
    Trackpad Disable Stays Set After Orig. Pref. Re-installed!

    Hi;

    I've found that whichever way I set the "Disable Trackpad When Mouse Is Present" using the modded Trackpad Preference Panel, it STAYS SET even if I then remove the modded Preference Setting & re-install the ORIG. 1! This is true running Leopard 10.5.6 on both my old PowerBook G4 15" 1.5GHz & my new 15" late 2008 MacBook Pro 2.8GHz! So this is the Best of Both Worlds... IF you keep a back-up of both Trackpad Preference Panels, JIC. As they have the same title, just keep them in separate folders OR re-name & move them just B4 swapping them in/out of the System/Library/Preference Panels.

    This works & MANY THANKS to "Kemo", for his research, supplying the Orig. Preference Panel, & posting his Notice!!!

    VR,

    Ron S.
     
  19. synth3tik macrumors 68040

    synth3tik

    Joined:
    Oct 11, 2006
    Location:
    Minneapolis, MN
    #19
    I did have the option on my unibody, before I plugged in a mouse. The thing that gets me is that I had selected to have the trackpad be ignored when a mouse was present, then the the option was no longer there and the trackpad as active.


    Kemo, you saved my Macbook. Either it was going back or the trackpad was coming out. I'm going to keep a copy close as I have a feeling that 10.5.7 is going to screw stuff up again. Got love Apple.
     
  20. michael.lauden macrumors 68020

    michael.lauden

    Joined:
    Dec 25, 2008
    #20
    only if you bring the jack johnson
     
  21. Lumio macrumors member

    Joined:
    May 20, 2008
    #21
    Hi, I copied the modded preferencefile, but my problem is, that on every reboot the trackpad gets enabled again, even if I connected a mouse. :|
     
  22. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #22
    That sounds really tedious.
     
  23. Bronzit macrumors newbie

    Bronzit

    Joined:
    Mar 23, 2009
    Location:
    Escondido, CA, USA
    #23
    Re: Lumio

    Sounds 2 me like the file didn't really get replaced. Was it really put into the correct folder?

    Possibly there's a permissions problem where you aren't being allowed to overwrite the old 1?

    Make sure the modded 1 is properly named, too.
     
  24. Bronzit macrumors newbie

    Bronzit

    Joined:
    Mar 23, 2009
    Location:
    Escondido, CA, USA
    #24
    Same-named files...

    Um, not really. Everyone 2 their own filing system. I just suggested 2 ways to do the same thing. Pick 1 or do it some other way.
     
  25. Lumio macrumors member

    Joined:
    May 20, 2008
    #25
    Hi,
    now I did it with terminal and after that I fixed the permissions (with Disk Utility)... same thing again: After restart Trackpad is availabl... I think it's becaus I have a Bluetooth Mouse that is not connected from the beginning on.
     

Share This Page