HOW TO UNBRICK IPHONE TUTORIAL (Phone gets stuck restoring)

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Jimmy Guphanti, Oct 23, 2011.

  1. Jimmy Guphanti macrumors 6502

    Mar 29, 2011
    Hello everyone,

    Today I discovered how to unbrick an iPhone that it is stuck restoring, and it worked on the first try. This problem usually happens if you restore after jailbreaking.

    (Mac only)

    1.) Put Device into DFU Mode

    a. Plug iPhone into Mac
    b. Make sure phone is off
    c. Hold Sleep for 10 Seconds
    d. After 10 Seconds continue to press sleep, but also press the home button
    e. After another 10 seconds, continue pressing the home button, but let go of the sleep button
    f. Open iTunes and it should detect the phone

    2.) Press restore

    3.) While it is restoring, download iFuntastic

    4.) Wait until the part of the restore when it gets stuck, and once it does get stuck, open iFuntastic

    5.) That's it! I am not sure how, but somehow opening the program slaps some sense into iTunes and unsticks it.

    Please tell me if this worked.
  2. Kashika macrumors regular

    Sep 8, 2010
  3. Granitel, Oct 23, 2011
    Last edited: Oct 27, 2011

    Granitel macrumors member

    Jul 27, 2011
    I have a jailbroken iPhone 3G IOS 4.2.1 (8C148) which is also stuck in restore mode (I'm on WinXP).
    - How to resolve locked up jailbroken iPhone stuck in "recovery mode" (see pictures)

    The best Windows DIY I can come up with all on my own to unstick it is the following:
    1. Unfortunately, there's no way possible to check the baseband version (since the iPhone is stuck in recovery mode & won't boot)
    2. Try to backup the jailbroken iPhone in WinXP iTunes even though the iPhone 3G won't boot (this may not be successful)
    3. Download the iOS 3.1.3 ipsw from iClarified
    4. Read how to unjailbreak the iPhone
    5. Hold the Windows keyboard SHIFT key while updating on iTunes
    6. Hopefully, this will ASK for the iOS 3.1.3 ipsw instead of loading iOS 5.0 automatically
    7. If it doesn't ask for the iOS 3.1.3 ipsw, at least the unjailbreak process should work (hopefully)
    8. If the unjailbreak worked, then downgrade to iOS 3.1.3
    9. From there, you do an untethered jailbreak on WinXP using the JailbreakMe jailbreak tool

    Since I've never done any of this yet I need to fix the iPhone 3G stuck in restore mode, let me know if you have better ideas or improvements on WinXP for getting a jailbroken iPhone 3G out of restore mode.

  4. Granitel, Oct 24, 2011
    Last edited: Oct 26, 2011

    Granitel macrumors member

    Jul 27, 2011
    BTW, is it possible to restore an iPhone 3G stuck in restore mode and save the data at the same time?

    NOTE: Googling, I see backup and sync are two different things:
    • A backup apparently saves some email settings, text messages, notes, call history, contact favorites, sound settings, widget settings, certain network settings, purchased music, TV shows, apps, and books; photos and video in the Camera Roll; device settings (for example, Phone Favorites, Wallpaper, and Mail, Contacts, Calendar accounts); app data; Home screen and app organization; Messages (iMessage, SMS, and MMS), ringtones
    • A sync saves music, podcasts, videos, ringtones, photos, email account settings, contacts, calendars, and bookmarks.

    Too bad my kid never backed it up nor synced (we don't even have iTunes on the WinXP computer!).
  5. Crystal-RX macrumors 68030


    Dec 22, 2008
    Seattle, WA USA
    Your question was how to restore the phone while saving your kid's info which is impossible.

    You can restore it to 3.1.3 and do not need blob, and then restore from back up.

    You can look at my old posts and I am sure I gave out information on how to restore Iphone 3G to 3.1.3. It ran faster anyway for 3G.
  6. Granitel, Oct 26, 2011
    Last edited: Oct 26, 2011

    Granitel macrumors member

    Jul 27, 2011
    This useful tidbit was unknown to me.

    It's good if I won't need saved SHSH blobs because I don't really understand (yet) what they are.

    Is this what you're referring to?

    Once I get the iPhone 3G out of recovery mode, I'll attempt the downgrade from 4.2.1 to 3.1.3:
  7. Granitel, Oct 26, 2011
    Last edited: Oct 26, 2011

    Granitel macrumors member

    Jul 27, 2011
    Thanks to your advice, I'm out of recovery mode!

    Now I'm stuck in "emergency call" mode (which may be because I have a T-Mobile SIM card in the iPhone 3G).

    So, I followed your advice as shown below to downgrade the iOS from iOS 4.2.1 to iOS 3.1.3:
    NOTE: This was all done in 'restore mode' (nothing was done in DFU mode yet).

    1. I first installed iTunes on the WinXP PC
    2. I then downloaded the iClarify iOS 3.1.3 for iPhone 3G (iPhone1,2_3.1.3_7E18_Restore.ipsw)
    3. I downloaded Tiny umbrella v5.00.12 to the WinXP PC
    4. I tethered the jailbroken iPhone 3G 4.1.2 stuck in recovery mode to the WinXP PC
    5. I opened Itunes: I held the shift key & then pressed the Restore button
    6. Itunes then asked for the ipsw file (I gave it the iPhone1,2_3.1.3_7E18_Restore.ipsw)
    7. After a while, Itunes gave me a 1015 error (which, I think, means I have the iPad baseband)
    8. I ran tiny umbrella and hit "exit recovery" & then unplugged the iPhone & tried to use it
    9. I then ran through the entire process again (and again I got the 1015 error).
    Tiny Umbrella says the versions are the following:
    • Device Model = MB702LL/A - iPhone3G
    • Installed Firmware Version = 3.1.3
    • Installed Baseband Version = 06.15.00-5.9_M3S2
    I had expected the phone to have all the desktop icons; but it doesn't let me get there (is this because the SIM card is for T-Mobil?). All I can do is make an emergency call.

    Was this supposed to be the expected results?
    If so, would someone kindly summarize the next expected steps?

    Thanks for all your help ... I much appreciate it and realize you don't have to help me ...

    Attached Files:

  8. Granitel, Oct 27, 2011
    Last edited: Oct 27, 2011

    Granitel macrumors member

    Jul 27, 2011
    To close the loop on that issue (and to provide help to anyone using this thread for future research), Crystal-RX (and others) kindly walked me through all the steps over in this thread to a complete recovery (sans data):
    - How to resolve locked up jailbroken iPhone stuck in "recovery mode" (see pictures)

    I spent an hour writing this up expressly so that others who have the same problem can follow easily the recovery sequence below (which took me very many days to decipher even with lots and lots of help) - but - if you follow it - you'll traverse the steps in just an hour or two!

    - Calling AT&T last summer to replace my kid's phone (which had a data block), I found out there is no way to put an iPhone on AT&T's network without being forced to pay for data (even with a data block).
    - I complained to AT&T vice presidents by phone and I filed a complaint to the FCC while I explored options to change the IMEI of an iPhone to my old broken Motorola RAZR on AT&T, but gave up after almost everyone on this forum vehemently advised against it & when both AT&T & the FCC closed the issue without resolution:
    * Why I want to learn how to spoof the IMIE of a USA Apple iPhone 3G or iPhone 3GS
    - However, my stubborn kid still wanted an iPhone for texting & games so I switched to T-Mobile & bought a jailbroken iPhone 3G iOS 4.2.1 baseband 06.15.00 off of Craigslist (with data off of WiFi)
    * Why I decided NOT to change the iPhone IMEI (I simply switched from AT&T to T-Mobile)
    - This worked almost flawlessly since August & my headstrong kid was happy ... with some very minor exceptions.
    - The first problem was how to remove a screen imperfection, which essentially met with stony silence:
    * Request advice on what causes this odd-shaped bubble or space under iPhone 3G screen
    - The more relevant (to this post) minor exception was that CyCorder wouldn't work on iOS 4.2.1
    - Why would Cycorder simply flash black & blank out on a jailbroken Ios4.x iPhone 3G?
    - Looking for an alternative free iPhone video recorder for the iPhone 3G came up relatively empty handed:
    - What video recorder application works on the iPhone 3G iOS 4.2.1?
    - It is relevant (see below) to note the main answer to the app-support question above was to downgrade to the better supported iOS 3.1.3 (which I didn't know how to do at that time so I just gave up on video support on the iPhone 3G 4.2.1)
    - Suddenly, without warning, the iPhone 3G iOS 4.2.1 baseband 06.15.00 stuck in iTunes recovery mode over the weekend.

    - My problem now was to save the data (my kid doesn't use iTunes because of its horrendous bloat)
    - Doing furious research, I found seemingly innumerable terms that I needed to learn just to understand what people were saying when I searched for solutions:
    * One users' experience with the technical terms of iPhone 3G usage
    - All attempts to exit recovery mode without iTunes failed, i.e., FixRecovery 4.2.1, Tiny Umbrella, RecBoot, iReb, etc.
    - That initial problem of saving the data then morphed to the question of how to re-install the iOS (which would wipe out the data so that cause was already lost).

    JAILBROKEN iPhone 3G 4.2.1 BB 06.15.00 STUCK IN RECOVERY MODE:
    - After much research, I installed iTunes on the main computer (which didn't have iTunes on it previously).
    - I downloaded the iClarify iOS 3.1.3 ipsw for iPhone 3G (iPhone1,2_3.1.3_7E18_Restore.ipsw)
    - And, thankfully, I also downloaded Tiny umbrella v5.00.12
    - Tethering the iPhone 3G 4.1.2 stuck in recovery mode to the WinXP PC, I opened iTunes
    - The original danger was that iTunes would load an updated iOS & baseband onto the iPhone; but those worries thankfully vaporized because the latest signed iOS for an iPhone 3G was 4.2.1 already and the baseband was already 06.15.00 (unbeknownst to me at that time).
    - In Itunes, to prevent iTunes from installing the latest 4.2.1 iOS, I held the keyboard shift key & then pressed the iTunes "Restore" button
    - Itunes then asked for the ipsw file (I gave it the iPhone1,2_3.1.3_7E18_Restore.ipsw from iClarify)
    * I presume this ipsw contains a lower baseband than the one I had so the baseband apparently didn't load.
    - After a while, Itunes gave me the expected 1015 error (apparently due to the iPad baseband)
    - I first ran tiny umbrella and hit "exit recovery" to get past that error (which probably worked without me knowing it).
    - Since some said to install the iOS twice to get past the expected 1015 error, I (probably unnecessarily) again ran the iTunes shift-restore install (and again got the 1015 error, which was surprising because doing it twice is supposed to work).
    - Hoping it would help, I clicked the Tiny Umbrella TSS button without researching what it did; that seemed to work but who knows what really worked in this particular instance.
    * I'm surprised I was able to downgrade the iOS from 4.2.1 to 3.1.3 without ever consciously skipping iBoot by putting the iPhone 3G into DFU mode!

    iPhone 3G 3.1.3 BB 06.15.00 STUCK IN EMERGENCY MODE:
    - At this milestone, the phone was stuck in "emergency-call only mode"
    - Tiny Umbrella reported:
    * Device Model = MB702LL/A - iPhone3G
    * Installed Firmware Version = 3.1.3
    * Installed Baseband Version = 06.15.00-5.9_M3S2
    - My next step was to activate (either with an active or inactive AT&T SIM card or to hacktivate with Redsn0w & SAM)
    - I still had my now-inactive AT&T SIM card so I chose to activate through iTunes which was the easiest method
    - Now I had an iPod with the familiar home screen sea of icons; but no phone.

    ACTIVATED iPhone 3G 3.1.3 BB 06.15.00 NEEDS JAILBREAKING:
    - My three choices for jailbreaking were Spirit, Redsn0w, and
    - I chose the easiest which was
    - WiFi encryption, at this point, was easy to set up for my home network
    - With Safari, I navigated to & moved the slider to begin the process
    - I eventually saw the message "Cydia has been added to the home screen"
    - So now my iPhone was jailbroken!

    - To unlock, I started Cydia & dutifully followed its prompts
    - It asked "Who Are You?" (I said "Hacker" although that was being generous)
    - Cydia started downloading packages & reloading data.
    - Cydia requested one of 3 essential upgrades (Essential, Complete, Ignore).
    - I let it do a complete upgrade & then it asked to "Close Cydia & Restart".
    - Following instructions to click on "Manage", I first clicked on "Manage Account" but that was the wrong "Manage" button.
    - I clicked on the open-book icon for "Manage" at the bottom of the Cydia screen (which was the right 'Manage' button) & pressed the "Sources" button in the center of the screen.
    - I hit "" & then "ultrasn0w" (which only then revealed itself to be version 1.2.4)
    - When done, I had to hit the home button to "Reaload Springboard"
    - Since the active T-Mobile SIM card was in the phone, zillions of text messages started arriving (it's my kid's iPhone)
    - At the home screen, I pressed Settings, General, Network, and changed "Enable 3G" from "ON" to "OFF" (not sure why)

    - My kid lost all the data ... but now, thanks to your help and from others, we started with a Craigslist T-Mobile jailbroken/unlocked iOS 4.2.1 iPhone 3G (baseband 06.15.00) which was stuck in iTunes restore mode - and now ended with a working T-Mobile jailbroken/unlocked iOS 3.3.1 iPhone 3G (baseband stayed the same)!

    Note: There was no need to save or load SHSH blobs! (whew!)

    The only remaining questions:
    Q: How did the iOS downgrade occur without going into DFU mode (i.e., the iBoot loader was still running AFAIK)? Maybe the TSS button in Tiny Umbrella allowed the downgrade without DFU mode???

    Q: At no point did the baseband change but many articles I read warned against upgrading the baseband. Which step in the process above 'would' have updated the baseband without my knowledge? Is the baseband inside the ipsw?

    Q: My kid transfers audio & video without iTunes; but I now realize we need a freeware tool to backup and sync data. What is the most recommended non-Apple tool for backup &/or sync?
  9. helpingmygirl macrumors newbie

    Dec 14, 2012
    Please help anyone?

    Hello guys...I am sorry to bother you but I Have been looking around almost every website to try and fix my gf's iphone. She was using it one day and all of a sudden the phone restarted itself and went into recovery mode.

    It is an iphone 3gs serial 88041
    It says baseband is 06.15.00-6.4_m3s2
    Firmware- 6.0.1
    device model MC555LL/A

    After countless hours of studying and researching and trying to find the cure for this problem I have finally been able to restore the iphone to os 6.0.1.
    BUT now for some reason, it is not letting me activate the phone. It keeps send me to the choose wifi page which I did, and then it says attempting to activate but it keeps failing. I have plugged it into itunes to try and activate it but it gives me an error message:confused:

    I know no one has to help me and I may be posting this in the wrong place and I am sorry if i am but will it be possible for someone to give me some advice please!!!
  10. chambone macrumors 6502a


    Dec 24, 2011
    6.15.00 is an iPad baseband, and I think that it is installed on a phone to unlock it. The restore probably re-locked the phone to a carrier other than where she's got her sim from, hence the activation error.
  11. MrMacNasty macrumors member

    Aug 27, 2010
    Thanks! This worked like a charm for me! I have an iPhone 4 and have been running iOS 4.0.1 forever which I couldn't upgrade from a jailbreak as I was always receiving errors when backing up or syncing via iTunes.

    I was content with not upgrading the OS for the longest time until many applications started requiring a new OS to install them. I finally decided to manually backup whatever I wanted to keep and do a restore to a new OS.

    However, the restore always got stuck at about the 75% mark for hours until I found this thread and downloaded ifuntastic which quickly unstuck it and completed the restore afterwords within just a few minutes. Awesome!


Share This Page