How to "uninstall" Git projects and Git itself?

Discussion in 'Mac Programming' started by Tomovich, Dec 21, 2015.

  1. Tomovich macrumors member

    Joined:
    Dec 5, 2007
    #1
    Hello

    Yesterday I installed git so I could use mkvdts2ac3 with this command line instruction:
    Code:
    git clone git://github.com/JakeWharton/mkvdts2ac3.git
    I didn't get what I wanted so now I want to uninstall everything but I do not know how. It's also not mentioned on the github page of the mkvdts2ac3 project. And how do I uninstall git afterwards?

    Thanks!
     
  2. ocabj macrumors 6502a

    ocabj

    Joined:
    Jul 2, 2009
    #2
    If all you did was git clone the repo, just delete the entire directory of the local repo to 'uninstall' the repo.

    As far as uninstalling git, why would you? If you install the XCode command line tools, git is part of that. So if you really have something against git, then uninstall the XCode CLI tools.
     
  3. Tomovich thread starter macrumors member

    Joined:
    Dec 5, 2007
    #3
    I haven't installed Xcode. I installed Git from a package I downloaded from the Git website. I don't have anything against Git, I just don't need it anymore. I'm no programmer and tried to use mkvdts2ac3 but that didn't went well.
     
  4. felt. macrumors 6502a

    Joined:
    Mar 13, 2008
    Location:
    Canada
    #4
    have you tried installing homebrew first by running
    Code:
    ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"
    then installing mkvdts2ac3 through brew with
    Code:
    brew install mkvdts2ac3
    because that's the correct way.

    Code:
    mkvdts2ac3-1.6.0 - by Jake Wharton <jakewharton@gmail.com> and
      Chris Hoekstra <chris.hoekstra@gmail.com>
    
    
    Usage: mkvdts2ac3 [options] <filename>
    Options:
      -c TITLE,  Custom AC3 track title.
      --custom TITLE
      -d, --default  Mark AC3 track as default.
      -e, --external  Leave AC3 track out of file. Does not modify the
      original matroska file. This overrides '-n' and
      '-d' arguments.
      -f, --force  Force processing when AC3 track is detected
      -i, --initial  New AC3 track will be first in the file.
      -k, --keep-dts  Keep external DTS track (implies '-n').
      -m, --nocolor  Do not use colors (monotone).
      --md5  Perform MD5 comparison when copying across drives.
      -n, --no-dts  Do not retain the DTS track.
      --new  Do not copy over original. Create new adjacent file.
      -p PRIORITY  Modify niceness of executed commands.
      -s MODE,
      --compress MODE  Apply header compression to streams (See mkvmerge's --compression).
      -t TRACKID,
      --track TRACKID  Specify alternate DTS track.
      -w FOLDER,
      --wd FOLDER  Specify alternate temporary working directory.
    
      --test  Print commands only, execute nothing.
      --debug  Print commands and pause before executing each.
    
      -h, --help  Print command usage.
      -v, --verbose  Turn on verbose output
      -V, --version  Print script version information.
    
    working fine.
     
  5. Tomovich thread starter macrumors member

    Joined:
    Dec 5, 2007
    #5
    I did install Homebrew but not for mkvdts2ac3. I used Git since that's what it said on the website.
     
  6. felt. macrumors 6502a

    Joined:
    Mar 13, 2008
    Location:
    Canada
    #6
    once installed just do 'brew update' then 'brew upgrade' to have the latest version of any installed packages (such as mkvdts2ac3)
     
  7. Tomovich thread starter macrumors member

    Joined:
    Dec 5, 2007
    #7
    Ok, I'll try that!
    And how can I delete Git? I already have a reply about deleting mkvdts2ac3 with Git.
     
  8. ArtOfWarfare macrumors 604

    ArtOfWarfare

    Joined:
    Nov 26, 2007
    #8
    How did you install it?

    If you ran an installer program with a GUI, you can probably start that same program again and it'll have directions for uninstalling.

    If you installed it via the command line, tell us what command you used so we can tell you how to undo it.

    If it was just a file you downloaded and stuck in a specific directory, simply delete that file and it'll be uninstalled.
     
  9. ghellquist macrumors regular

    Joined:
    Aug 21, 2011
    Location:
    Stockholm Sweden
    #9
    First, there really is no need to remove
    The quick and dirty way. It will leave a few (very small) config files.

    Open a terminal.
    whereis git

    This will tell you what catalog git is on. As example, /usr/bin
    There will be a number of files called git and possibly git- something.
    Check on the net what the programs are and then delete them.
     
  10. Tomovich thread starter macrumors member

    Joined:
    Dec 5, 2007
    #10
    Ok, I reopened the dmg I downloaded from the Git website and found a README file. In there it said I had to run a .sh script which I did. I got the message "Uninstalled" afterwards.

    When I now open Terminal and type "whereis git" I get /usr/bin/git. When I go to that directory, I can't find it. Strange too that when I go to the HD then I can't find the /usr directory either. But when typing this location into "Go to" then it opens. It looks like a hidden directory.

    The /usr directory, is it installed by Git or is it a part of OS X?

    In each case, thanks for the help thus far!
     
  11. 556fmjoe macrumors 65816

    Joined:
    Apr 19, 2014
    #11
    /usr is part of OS X and all other Unix-like systems. /usr/bin/ is a directory containing a bunch of executable binaries (hence the "bin"). /usr/bin/git is the actual git binary within this directory, which if missing means git is no longer installed.
     
  12. ArtOfWarfare macrumors 604

    ArtOfWarfare

    Joined:
    Nov 26, 2007
    #12
    whereis might have a (no longer valid) cache so that it's able to find things faster for you.
     
  13. Tomovich thread starter macrumors member

    Joined:
    Dec 5, 2007
    #13
    Ok, thanks for the help!
    Is /usr/bin/git the only place where Git itself and the things I installed with it are placed?


    @ felt: if I want to use mkvdts2ac3, then I must install Homebrew and after it I must first install the libraries it depends on:
    Code:
    brew install mkvtoolnix
    Code:
    brew install ffmpeg
    Code:
    brew install rsync
    and then finally
    Code:
    brew install mkvdts2ac3
    That's the only correct way?
     
  14. hiddenmarkov, Dec 30, 2015
    Last edited: Dec 30, 2015

    hiddenmarkov macrumors 6502a

    Joined:
    Mar 12, 2014
    Location:
    Japan
    #14

    Your git repo files would be wherever you set them up, if set up. When I use git I have repo's push/pull from certain locations on my MBP.

    IIRC, Mac OS natively installs git now in command line. Seem to recall this as last I installed it and looked for the CLI portion (github historically made these 2 DL's....one gui and one CLI, on the user to pick how theywnted to work it) from github they said oh its in Mac OS now, its no longer an install. Not sure about your install of it. Would this be a gui interface to it perhaps?

    The home-brew install is the only correct way in the sense its the cleanest and easiest. Technically I could be bitter old school and say real men/women build off source lol. Some actually believe this the better way.

    Generally for CLI application installs home brew is kind of the preferred way to do it. Assuming your CLI application has a recipe for it.

    As the nice thing about home-brew is creates its own special place in the system to install ported CLI apps to Mac OS. It avoids sticky matters of say running commands as sudo. In the home-brew environment you have assumed root rights off the bat in the home brew realm it creates. Saves typing sudo a lot. Its only 4 little letters. But late at night, bit tired...you can forget to to type them and make work for yourself. Sometimes you don't get the denied permissions off the bat. Its minutes into the process where your application goes you can do 9/10 things as mere peasant user....now let me fail you epically on 10 that needed sudo elevation.

    Another nice feature to home brew is application updates. Assuming its maintained and the maintainer on the ball you run periodic check update commands in CLI and if there it handles the updating for you. This a a nice feature as I have some CLI applications not in home-brew I have to track down updates. And work out installs on them. Ie. do I want old version side by side, do I make a new new install folder and work out path redirects, do I have to remove the old install, etc.


    The method you used may have installed this in normal system file areas. Not a bad thing, but adds overhead. One of them being your uninstall question gets complicated. With home-brew uninstall is just another a slight variation to the install command. Bit late for this now but the TL;DR is if you see CLI application its highly recommended to see if in home-brew to make life potentially better.
     
  15. Tomovich thread starter macrumors member

    Joined:
    Dec 5, 2007
    #15
    I'm way too late reading this but I've finally managed to take some time to read this. Thanks for your extensive reply, it's a lot more clear now!
    I've managed to reinstall Homebrew and it's actually nice and quick to work with. Didn't think that was possible without having any Terminal knowledge. I'm using mkvdts2ac3 a lot right now and the results are perfect!
     

Share This Page