How to unlock iPhone 3G on 3.1.3

Discussion in 'Jailbreaks and iOS Hacks' started by b33eazy, Mar 8, 2011.

  1. b33eazy macrumors member

    Joined:
    Jul 7, 2009
    #1
    My iPhone 3G was on 4.0 and unlocked, but it killed my battery. So I downgraded it to 3.1.3.. And I tried Spirit and got an error (I will post error I got below). But I read somewhere I would need to activate my iPhone 3G for it to be jailbroken. So my question is: what steps to I need to follow to Jailbreak and unlock it...
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    You can use redsnow to jb and then install Ultrasnow from cydia to unlock.
     
  3. b33eazy thread starter macrumors member

    Joined:
    Jul 7, 2009
    #3
    Which version of Redsnow because 0.9.5b5-5 doesn't work with it: it just says unrecognizable when I select 3.1.3 (my current fw).
     
  4. b33eazy thread starter macrumors member

    Joined:
    Jul 7, 2009
    #5
    I have Windows: I don't think that works with Windows..
     
  5. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #6
    1. Make sure your phone is connected to internet via wifi.
    2. Open safari and type in Jailbreakme.com
    3. slide to jailbreak it.
    4. Back to home screen and open Cydia,
    5. click on repo666.ultrasn0w.com, install ultrasn0w 1.2
    6. If you have T-Mobile, go to setting, general, network setting and disable 3G
    7. plug in your sim and you are good to go.
     
  6. b33eazy thread starter macrumors member

    Joined:
    Jul 7, 2009
    #7
    I don't know how to activate it, so I can't open safari or any other thing... How do I activate it? I have a T-mobile sim...
     
  7. eastercat macrumors 68040

    eastercat

    Joined:
    Mar 3, 2008
    Location:
    PDX
    #8
    Why don't you go to iclarified for tutorials? Redsnow will hacktivate. Or you can get a pre-paid AT&T sim to activate it.

     
  8. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #9
    for 3.1.3, use Redsn0w 0.9.4. Like eastercat said above, Iclarified.com will give you all the tutorials including link for this version of redsn0w.
     
  9. b33eazy thread starter macrumors member

    Joined:
    Jul 7, 2009
    #10
    Is there a link for that somewhere I could only find dead links for that version of Redsn0w...l.
     
  10. b33eazy thread starter macrumors member

    Joined:
    Jul 7, 2009
    #12
    When I select 3.1.3 in that Redsn0w it says, "Unable to recognize specified IPSW." I selected 3.1.2 and it works fine, I guess... It's installing now...
     
  11. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #13
    Yes, you need to click on 3.1.2 and not 3.1.3 even your Iphone has 3.1.3.
     

Share This Page