How to unlock iPhone 3G running 3.1.3

Discussion in 'Jailbreaks and iOS Hacks' started by Kenzembo1, May 21, 2010.

  1. Kenzembo1 macrumors 6502

    Joined:
    Dec 22, 2008
    Location:
    Youngstown, OH
    #1
    Can anyone link me to a good guide on how to unlock an iPhone 3G running 3.1.3?

    I've scoured google and the forums here and I can't find a link or comprehensive guide on how to perform this operation.

    If anyone can help me it would be greatly appreciated! :)

    P.S.- I'm kind of a newb when it comes to unlocking devices, so please nothing too complicated.
     
  2. pixelated macrumors 6502a

    pixelated

    Joined:
    Oct 21, 2008
    #2
    If it's been upgraded to 3.1.3 you cannot unlock.
    This upgrades the Baseband to 05.12.01 for which an unlock has not been released.

    IF your 3G was one of the VERY FIRST made, it will have the bootloader 05.08, which allows for your Baseband to be downgraded, then unlocked.
    ^^this is very unlikely.

    You can download fuzzyband (the tool to perform the downgrade) from cydia to check compatibility.
     
  3. Naethyn macrumors regular

    Naethyn

    Joined:
    Feb 6, 2010
    #3
    However, if you downgrade back to 3.1.2 and jailbreak with either blackra1n or redsn0w then if your baseband is the very rare 5.08 then downgrade with Fuzzyband and use the Cydia ultrasn0w app to unlock. Very simple.

    I suggest when downgrading your firmware use DFU mode because it wipes your iPhones memory putting it back at the 2.0 Firmware it was when everyone got them.
     
  4. pixelated macrumors 6502a

    pixelated

    Joined:
    Oct 21, 2008
    #4
    He has no need to downgrade, as he can JB 3.1.3 with redsn0w.
    OP: Your baseband will not be 5.08, this is the desirable yet elusive bootloader... It determines if your baseband can be downgraded.
    If your 3.1.3 FW was stock, not custom, your baseband will be 05.12.01
     
  5. portfola macrumors newbie

    Joined:
    May 22, 2010
    #5
    Similar problem unlocking

    I have iphone 3G purchased Nov 2008. Foolishly upgraded to 3.1.3 before I ever knew about jailbreaking.

    I'm trying to unlock for a trip to Europe. This week I JBed with Spirit successfully. I needed to downgrade current baseband (05.12.01) so got Fuzzyband but it says I have Bootloader 05.09 which is Not Supported.

    Any way to unlock this guy immediately or am I stuck until something new is released?
     
  6. pixelated macrumors 6502a

    pixelated

    Joined:
    Oct 21, 2008
    #6
    you are stuck until something new is released
     
  7. portfola macrumors newbie

    Joined:
    May 22, 2010
    #7
    bummer that's what I thought. thanks for the reply
     
  8. Naethyn macrumors regular

    Naethyn

    Joined:
    Feb 6, 2010
    #8
    But if he restores to a stock 3.1.3 Firmware from a site like felixbruns then can't he unlock.
     
  9. pixelated macrumors 6502a

    pixelated

    Joined:
    Oct 21, 2008
    #9
    stock 3.1.3 = 05.12.01 Baseband.
    whats not to get here?
     
  10. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #10
    Corrected to reduce confusion.

    You made me laugh. :) Thanks.
     
  11. Mystikal macrumors 68020

    Mystikal

    Joined:
    Oct 4, 2007
    Location:
    Irvine, CA
    #11
    When we people understand:
    1) Research before you do anything
    2) GOOGLE IS YOUR FRIEND
     
  12. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #12
    Its not possible right now.
    Wait a month or 2.
    There should be a new unlock out.
     
  13. Kenzembo1 thread starter macrumors 6502

    Joined:
    Dec 22, 2008
    Location:
    Youngstown, OH
    #13
    Thank you guys!

    Thank you guys for walking me through everything and taking the time to explain some of these common errors that I've been running into trying to unlock my device with this version firmware.

    One more question, I've heard that it's possible to unlock v.3.1.3 if you're using a first generation (2g/EDGE) iPhone...is this true?
     
  14. pixelated macrumors 6502a

    pixelated

    Joined:
    Oct 21, 2008
    #14
    yes
     
  15. Kenzembo1 thread starter macrumors 6502

    Joined:
    Dec 22, 2008
    Location:
    Youngstown, OH
    #15
    Can you please explain how or provide me a link with a walkthrough so I can unlock my first gen iphone and use it until I get the new one next month.

    I'm desperate lol. I just sold my 3G in preparation for next month's release and I'm using an old Moto Razr :(
     
  16. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #16
  17. Kenzembo1 thread starter macrumors 6502

    Joined:
    Dec 22, 2008
    Location:
    Youngstown, OH
    #17
    Thank you! Looks easy enough...I'll report back here if I run into any problems :)
     
  18. Maverick1337 macrumors 65816

    Maverick1337

    Joined:
    Nov 4, 2008
    #18
    I wish I could unlock my 3G. I got my 3G on launch day and when I tried Fuzzyband, it shows I have the 5.09 bootloader :(
     
  19. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #19
    You're out of luck for now bro.

    Good luck.
     

Share This Page