How to update Intel SSD Firmware

Discussion in 'MacBook Pro' started by reidnez, Aug 30, 2013.

  1. reidnez macrumors newbie

    Joined:
    Aug 21, 2013
    #1
    Hey all...put an Intel SSD in my late '08 MBP and have been experiencing serious issues since...every few minutes or so, it will beachball and be totally unresponsive for a period of a few seconds. It doesn't matter what I'm doing or what applications are open; even with a fresh reboot and only one Safari browser window open, it happens. I often have to work on this machine so it's very irritating.

    Following others' advice, I enabled TRIM...it seems to have maybe helped a bit, but the issue still persists. I've also been told to try and update the SSD Firmware. Intel mentions something about "TRIM support" with the firmware update, so I'm encouraged that this might resolve my issue...and even if not, it's just a good idea to have the latest firmware.

    I downloaded the .iso from Intel's site. Apparently you are meant to put this on a DVD-R or thumb drive and boot from it, and it will update the SSD firmware. I actually couldn't even clone the .iso onto a thumb drive with Disk Utility, and instead had to do it on a Windows machine...but I eventually got that far at least.

    I confirmed that the thumb drive has the boot partition as it should. But when I reboot holding "option", the thumb drive does not show up as a bootable volume...so I'm kinda dead in the water.

    Has anyone found a resolution to this? Next step is to pull out the SSD and connect it to a Windows machine as an external, then try to install it that way (assuming Windows will boot from the .iso), then put it back in my Mac. I feel like there really has to be an easier way...does Intel just not bother supporting Macs with firmware updates? It seems that OSX (logically enough) won't register a volume as bootable unless it actually has a copy of OSX on it. Makes sense, but it's hampering my efforts here. Intel's site lists this update as OSX-compatible, but doesn't really post any instructions. And trolling various forums I see many, many others are having the same issue.

    Thanks in advance.
     
  2. hammo123 macrumors newbie

    hammo123

    Joined:
    Jun 9, 2013
    #2
    I had all sorts of issues with an Intel 520SSD in my MBP 2011...
    You don't say what model yours is but the firmware update process is the same I imagine...I couldn't get a USB flash drive to work with the iso. i downloaded from Intel but had success with burning it to a CD/DVD & booting from that..(holding key: C on reboot)
    It didn't help my issue but I guess it's worth a try

    I got it working eventually but it was never reliable or something i felt i could trust so I sold it on Ebay to someone with a PC & bought a Samsung 840...cheap & cheerful...& it worked like magic..
    I seem to think some Intel SSDs don't agree with certain Macs...especially the 520 series
     
  3. jdelgado macrumors regular

    Joined:
    Oct 25, 2009
    #3
    i have a 520 series (480GB) in a MBP mid-2012 and have had no issues whatsoever. I installed the drive as it came from the factory and did not enable trim. The only thing I checked was that it had the latest firmware.
     
  4. kcrossley macrumors member

    Joined:
    Mar 22, 2009
    #4
    Did you ever manage to update your firmware and if so how did you do it?
     
  5. kappaknight macrumors 68000

    kappaknight

    Joined:
    Mar 5, 2009
    #5
    Yeah, some SSD's have issues when paired with a SATA II vs. SATA III connections. I had a Micron SSD that beach balled like hell too. It was complicated to update the firmware - required a Windows instance in my case... and it still never really worked right on my early 2011 MBP.
     

Share This Page