How to update to ios 5.0.1 Jailbroken, Hacktivated from ios 4.0 in 3gs Old Bootrom?

Discussion in 'iPhone' started by steelnerves, Apr 13, 2012.

  1. steelnerves macrumors newbie

    Joined:
    Apr 13, 2012
    #1
    I am from India, Bought this Iphone **3gs Old Bootrom** in U.S..(Model :
    MC136LL/A - iPhone3GS)
    Current Version : 4.0 - **Jailbroken, Hacktivated and UnTethered - Unlocked with Ultrasn0w**
    BB : 05.13.04-6.4_M3S2
    Serial # :87932 = 2009-32nd week.
    System : Windows 7
    Itunes Version : 10.4.1.10​

    Saved SHSH Files are as blw:

    iphone2,1-4.0.1,
    iphone2,1-4.0.2,
    iphone2,1-4.0,
    iphone2,1-4.1,
    iphone2,1-4.2.1,
    iphone2,1-4.3.5,
    iphone2,1-5.0.1

    **I would like to upgrade to 5.0.1 Jailbroken, Hacktivated and UnTethered with the same BB or 6.15(If no option) :)**

    Let me tell what I did.. Downloaded Official IPSW for 5.0.1 for 3gs, Then created a custom firmware using Redsn0w(not sure which version coz I now hav 10 versions of redsn0w). Then tried restoring with Itunes 10.4.1.10 got errors like 3194.1600 and 1604 after fixing all that(by changing HOSTS running Tinyumbrella and everthing)..
    **then came the weirdest part got error 10(Itunes does not hav that in the errors list.**
    After all this going useless(I was still able to use my phone).

    ***No PROPER Answer for Error 10 on the INTERNET***:confused::confused:

    Then some how found the compatible Redsn0w version for the ipsw (Version : redsn0w_win_0.9.9b9d and the Latest redsn0w_win_0.9.10b6) tried jailbreaking with that.. It was going fine with the Matrix thing on the phone and suddenly got the blw error

    Code:
    "fix Mounting rootfs as read-only' 
    ERROR!
    AppleBCMWLANCore::handleOKitBusyWatchingTimeout():
    Error, no successful firmware download > after 60000 ms!! Giving
    up.."
    96810_b5351326163093c5b357658588ab0.jpg

    ***No PROPER Answer for This error as well on the INTERNET:confused::confused:***

    **Since the Jailbreak was interrupted in half way through my Version 4.0 crashes, I guess and my iphone is in Recovery Mode :mad::mad: all the time..But Tinyumbrealla still shows that I am on version 4.0..**


    I tried other thing as well like stitching the SHSH blobs to the cust firmware and restoring with Itunes stitch it with Official Firmware and tried it all gives me Error 10

    **Hoping to find my Savior from this..!! :)**
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    Why not contact AT&T and have them officially unlock it? They do that now and you dont need to have an account with them to get the unlock.
    And then just update to stock 5.1 once you receive the email that your iphone has been unlocked.
     
  3. boonme macrumors newbie

    Joined:
    Oct 3, 2008
    Location:
    Everywhere
    #3
    Applejuiced do you have to take the phone in to AT&T to do this? Because this guy says he is in India. So they won't have an AT&T shop there.
     
  4. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #4
    Nope.
    You just need the imei.
    I just unlocked my cousins 3GS and she's in Europe with it right now.
    I just called AT&T and had them officially unlock it.
     
  5. steelnerves thread starter macrumors newbie

    Joined:
    Apr 13, 2012
    #5
    Would you mind doing that for me..?? I have no one in U.S..!!:(
     
  6. steelnerves thread starter macrumors newbie

    Joined:
    Apr 13, 2012
    #6
    Thank You..!!

    Thank You for your response Applejuiced...!!

    I had my friend bring his laptop for me and I updated using ITUNES to custom made 5.0.1 which was made using Redsn0w_win_0.9.10b6(Only with Install Cydia).. but my phone was locked.. It was asking for "Official SIM" on the set up screen..

    Then after watching a few videos in YouTube realized that when creating a custom IPSW.. I should "Check mark" Install Cydia and Deactivate as well to Hacktivate the phone.. Instead of creating a Custom IPSW.. I Jailbreaked using Redsnow same version as above by slecting Install Cydia and Deactivate..

    Even after doing that my phone is still asking for a VALID SIM and I am stuck there..:(:(

    Kindly tell me what to do now..??
     

Share This Page