How to upgrade existing bootcamp 2.1 to bootcamp 3.0 (snow leopard)

Discussion in 'Windows, Linux & Others on the Mac' started by Jottle, Aug 28, 2009.

  1. Jottle macrumors 6502

    Joined:
    Oct 17, 2003
    #1
    Maybe I'm just overthinking this, but Apple never posted a KB article about how to upgrade an existing bootcamp partition with the new snow leopard bootcamp 3.0 drivers. I'm assuming if you already have bootcamp 2.1 you boot up in boot camp and then insert the snow leopard disc in order to upgrade the drivers to 3.0 correct? Or do I have to erase my stupid bootcamp partition and reinstall it all over again using the new leopard boot camp assistant in order to get to 3.0?
     
  2. r.j.s Moderator emeritus

    r.j.s

    Joined:
    Mar 7, 2007
    Location:
    Texas
    #2
    What about inserting the SL disc, like you have to with the Leopard disc?
     
  3. Jottle thread starter macrumors 6502

    Joined:
    Oct 17, 2003
    #3
    oops. That was a typo in my original post. Fixed. I'm assuming you just have to insert the snow leopard disc to use the new 3.0 drivers, correct?
     
  4. r.j.s Moderator emeritus

    r.j.s

    Joined:
    Mar 7, 2007
    Location:
    Texas
    #4
    Have you tried it yet?
     
  5. dimme macrumors 65816

    Joined:
    Feb 14, 2007
    Location:
    SF, CA
    #5
    I updated my windows 7 install but just putting in the SL disk and clicked on install boot camp.
     
  6. PowermacG5 macrumors regular

    PowermacG5

    Joined:
    Jul 24, 2003
    Location:
    Grand Rapids, MI
    #6
    Very Interested

    i am thinking the same things. I plan on putting snow leopard disc into my imac while booted in to windows to see what happens later this weekend.
     
  7. McShizzel macrumors regular

    Joined:
    Oct 29, 2008
    Location:
    Canada
    #7
    Just drop in the disk while your in Windows, installed fine on Vista Ultimate 64bit.
     
  8. GeekLawyer macrumors demi-god

    GeekLawyer

    Joined:
    Jun 2, 2007
    Location:
    The post is coming from inside the house!
    #8
    Yes. Run the installer on the SL disc while bootcamped into Windows. As I recall there are three options once the installer opens. The third is the one that will update your Bootcamp to 3.0. I didn't have any trouble with my XP partition after upgrading.
     
  9. Miharu macrumors 6502

    Miharu

    Joined:
    Aug 12, 2007
    Location:
    Finland
    #9
    So does the Snow Leopard disc include 64-bit drivers as well?
     
  10. cuestakid macrumors 68000

    Joined:
    Jun 14, 2006
    Location:
    San Fran
    #10
    It must as I have a 64 bit install of Vista and it worked fine however you may have to manually run the 64-bit installer.
     
  11. ecran macrumors newbie

    Joined:
    Aug 31, 2009
    #11
    I still have problems upgrading my windows xp boot camp 2.1 to 3.0. I inserted sl disk and I ran the installation option under BootCamp drivers.

    Then I get the error mesage: Boot Camp installer completed. The installer encountered errors before Boot Camp could be configured. To try these operations at a later time, please run the installer again.

    I have ran it several times with the same result. Anybody getting this error message?

    I'm running Bootcamp 2.1 on Windows XP SP3 on an early 2009 Unibody MBP.
     
  12. RITZFit macrumors 65816

    RITZFit

    Joined:
    Sep 16, 2007
    Location:
    In my Corner
    #12
    I think 3.0 has some sort of conflict w/ sp3. After a fresh boot camp installation w/ xp sp2 I used the 3.0 drivers from SL off the bat. When I tried to run sp3 I was given some error which resulted in the installer quitting without undoing it's changes (screwed my installation...)
     
  13. Trinite macrumors regular

    Joined:
    Oct 22, 2010
    #13

    Hi,

    Just wanted to give this a bump. I'm having exactly this problem, in this same situation. Does anyone have any suggestions?

    I should say that Bootcamp seems to be running fine; it's not like I'm having problems. But I feel like I should update if I can.

    Thanks!
     

Share This Page