how to upgrade jailbroken 2.2 iphone 3g to 2.2.1 and unlock

Discussion in 'Jailbreaks and iOS Hacks' started by gh0001, Feb 20, 2009.

  1. gh0001 macrumors member

    Joined:
    Sep 10, 2008
    #1
    hi, i have a jailbroken iphone 3g 2.2 (5G77), with firmware 2.28.00.

    can someone let me know the best way to upgrade to a jailbroken 2.2.1 and then unlock? Do i need to backup my iphone first in iTunes to keep the apps?

    thanks for the help.
     
  2. jmann macrumors 604

    jmann

    Joined:
    Dec 8, 2007
    Location:
    bump on a log in a hole in the bottom of the sea
    #2
    Always make sure that the iphone is backed up in itunes, and then use pwnage tool to upgrade to 2.2.1.
     
  3. Theaser macrumors 6502

    Theaser

    Joined:
    Dec 30, 2008
    #3
    There is no 2.2.1 unlock yet, only on 2.2
     
  4. gh0001 thread starter macrumors member

    Joined:
    Sep 10, 2008
    #4
    thanks guys. if you have a 2.30 firmware, how to downgrade it so that you keep the option of unlock open?
     
  5. nowayjoze macrumors newbie

    Joined:
    Jul 1, 2008
    #5
    I'd like to know as well. I'm selling my iPhone Edge to buy the 3G. If I buy a brand new one, it's gonna have 2.30 firmware. Is this reversible and go back to FW 2.80?
     
  6. Tokiopop macrumors 68000

    Tokiopop

    Joined:
    Dec 6, 2008
    Location:
    West Yorkshire, UK
    #6
    Guys. You CANNOT downgrade the baseband (without taking the chip out at least, which can brick your iPhone). You CAN downgrade the firmware, but that is it.

    If you get a new phone on the latest firmware (2.2.1), it will have the latest baseband. Meaning you can't software unlock. But most phones are being sold on 2.1 and 2.2.

    If you're not on 2.2.1 yet, but you want to be and still have the option to unlock, use PwnageTool to make a custom firmware to update the firmware, but not the baseband. Enabling the soft unlock known as yellowsn0w :)

    If anyone's on windows and they cannot get acess to a Mac to use PwnageTool, I have a custom IPWS on 2.2.1, but still with the 02.28.00 they can have. PM me if you want it. All you have to do if hold shift, then click 'Restore' in iTunes, and choose my custom firmware. This'll upgrade to 2.2.1, it wont update the baseband, and it will also install Cydia.

    Oh, if you're on the old 'Edge' iPhone you can unlock on all the new firmwares ;)
     
  7. jmann macrumors 604

    jmann

    Joined:
    Dec 8, 2007
    Location:
    bump on a log in a hole in the bottom of the sea
    #7
    That is why you upgrade using pwnage tool, to prevent the baseband from being updated, and that lets you still use yellowsn0w.
     

Share This Page