How to upgrade my iMac 400 slot loading

Discussion in 'Mac Basics and Help' started by Mac599, Jul 3, 2007.

  1. Mac599 macrumors member

    Joined:
    Apr 23, 2007
    #1
    I tried to boot with the OS X disk i have but it comes up with some errors and i have to reboot it and it just keeps doing that.
    Some thing about not finding a file. forgot what file it was.
    The disk is OS X 10.4.9 dvd
    i have it on cd's mayne that would work better? do I need to do a firmware update or some thing?
     
  2. brasscat macrumors 6502

    brasscat

    Joined:
    Jun 9, 2007
    Location:
    Dallas, Texas
    #2
    Sounds like you have a dirt disk. Try cleaning the media (even if it looks good to the eye), and try it again.
     
  3. Mac599 thread starter macrumors member

    Joined:
    Apr 23, 2007
    #3
    ok will try that now.
    ok the error is unable to find diver for platform powermac 2,2
     
  4. iHerzeleid macrumors 6502a

    iHerzeleid

    Joined:
    May 5, 2007
  5. Mac599 thread starter macrumors member

    Joined:
    Apr 23, 2007
    #5
    I have been searching for them but can't find them?
    have a link to them?
     
  6. Mac599 thread starter macrumors member

    Joined:
    Apr 23, 2007
    #6
    Should the iMac g3 400 with a plan DVD be able to read burn DVD disk?
    I can't get it to read the disk, just says it wants to format it then kicks it out.
    These are write one time dvd's. has no problem with reg cd's that i have burn.
     
  7. RedBear macrumors member

    RedBear

    Joined:
    May 9, 2007
    #7
    Careful! Firmware update 4.1.9 required!

    First off, before you even attempt to boot any OS X disc on any iMac G3 you MUST apply firmware update 4.1.9 from a writable install of Mac OS 9.1 or later. It must be installed on a bootable and writable partition, so you can't just boot from a Mac OS 9 install disc and apply the firmware from a USB key or something. Mac OS 9.1 or later must be installed to the hard drive. Just read the notes that come with firmware update 4.1.9. The original iMac G3 models that only took a maximum of 512MB of memory have a different firmware update version like 1.2.4 or something, but the model you have there requires 4.1.9.

    Now, when I say "requires" I mean your iMac G3 will DIE from a bizarre video problem if you do not have that firmware update, and all it takes is booting from a Mac OS X install disc, or even some utility CD that boots a Mac OS X system kernel. If your iMac starts exhibiting weird video problems, DO NOT reset the PRAM as that will only make the problem much worse and will make it very complicated to recover the system. Just get the firmware update installed on there as soon as possible if you start having any video issues.

    That said, you don't seem to be complaining about any video problems, so hopefully your iMac already has firmware 4.1.9 and it is safe to boot Mac OS X. Going back to what you actually said in your initial post, you said you have a 10.4.9 DVD. The very newest retail box version of Tiger still contains 10.4.6, so I have a feeling that what you're holding there in your hand is a restore disc that came with an Intel Mac, and a very new Intel Mac at that. Using a restore disc to install Mac OS X on a different computer model has never worked well because restore discs are missing some drivers required by other Mac models. This probably goes double for trying to use an Intel Mac restore disc on a PowerPC G3 Mac. If all you've been getting is some kind of text screen or error message before the system really comes up, that may have saved you from the firmware issue for now. If this is the case and you do not have firmware 4.1.9 installed yet, count yourself very lucky that you haven't killed your iMac.

    If the CDs you mention are also restore discs from some other Mac they won't work either, but if they are the retail version of Mac OS X install discs I'm sure they will work. Just be forewarned once again about making sure you have the latest firmware, or your machine WILL die very quickly after booting from any valid Mac OS X disc. Google for "imac firmware update 4.1.9" and go to the first link to find it.

    Oh yeah, and in your last comment you seem to be saying that the DVD is a burned copy of something. If it is bootable at all a burned copy should work fine. Obviously the drive is reading the disc well enough to give you that error message. But, sometimes burns are corrupted for one reason or another. You can try reburning the disc at a slower speed. Of course if it is just a restore disc it still won't work no matter how perfectly it was burned or how good the DVD drive is that reads it. It still won't work.

    The same caveat applies to cloning a Mac onto the hard drive of a different Mac model, or cloning onto an external drive and trying to boot from that drive on a different Mac model. This will often not work unless the original Mac had OS X installed from retail install discs, in which case you can use the cloned disk on any Mac with the same type of processor (PowerPC or Intel). PowerPC and Intel Macs will not boot from each other's hard drives without special tricks.

    Oh, and just in case you're downloading this stuff from The Pirate Bay or something (I don't care either way) you also need to watch out for all the hacked versions of OS X that are made to run on non-Apple Intel-based computers. Those definitely do not work on real Apple computers.

    Good luck.
     
  8. Mac599 thread starter macrumors member

    Joined:
    Apr 23, 2007
    #8
    Thanks for taking the time to help me here. that was some post you just did. :)
    I have been using my Mac mini disk trying to do the upgrade so that would be the error then from my mini disk.
    Good to know that I can't use the mini disk to install it.
    I found the firmware update 4.1.9 on the apple site and ran it and it ran and then closed , didn't ask me to reboot or anything?
    How do i check what firmware it has now?
    I was trying to use disk I burn on my PC as the mini only has a cdburner in it were my PC has a DVD burner. so I guess the older mac can't see or use the PC disk like the new Mac will?
    Thanks for the help again.
     
  9. Mac599 thread starter macrumors member

    Joined:
    Apr 23, 2007
    #9
    I did a boot with the cmd-opt-o-f keys and got this at the top of the screen.
    apple Powermac 2,2.3 0 f3. Boot Rom
    So why won't the firmware install? or is it installed?
    Thanks for the help with this.
     
  10. RedBear macrumors member

    RedBear

    Joined:
    May 9, 2007
    #10
    Checking the firmware version

    Oh, did I not mention how to check the firmware version? I don't think you ever did say what version of Mac OS you are running at the moment, but in both OS 9 and OS X there is an app called Apple System Profiler that gives you a ton of information about the software, firmware and hardware in your computer. In OS 9 you should find the System Profiler in the Apple menu, in OS X it's an application in the Utilities folder, or the easiest way to get to it is to open the "About this Mac" option from the Apple menu and click the "More Info..." button, which will open the System Profiler app. Somewhere in there you will find the firmware version. It might be called "Boot ROM". I don't know if there is a way to find out the firmware version from within Open Firmware.

    Again, if you were trying to run the firmware updater under OS X or in the Classic environment, that won't work. You have to be booted from an OS 9.1, 9.2.1 or 9.2.2 installation in order to run the updater. Normally the updater will ask you to restart and you'll see the update installing itself after the system restarts. Without knowing more about your system at the time you were trying to run the update, I have no idea why it would just run and close without doing anything.

    Good luck.
     
  11. Mac599 thread starter macrumors member

    Joined:
    Apr 23, 2007
    #11
    Thanks , i did get it to work. I had to do a few other updates and then the firmware work.
    Using OS X in it right now. thing runs so nice I can't believe how good it runs.
     

Share This Page