How to Use the New One-Handed Keyboard in iOS 11

MacRumors

macrumors bot
Apr 12, 2001
7,165
8,350
0
19
www.macrumors.com



There are a lot of little small tweaks and feature changes buried in iOS 11, and an option for a one-handed keyboard is one of them. With the one-handed keyboard, the entire on-screen keyboard can be shifted to either the left or the right so you can type more comfortably with a single hand even with a phone as large as the iPhone 7 Plus.

The feature is compatible with 4.7-inch and 5.5-inch iPhones, although it appears it may not work on 4.7-inch iPhones if display zoom has been turned on.


Once you know the feature is available it's easy to get to and activate, as long as you have multiple keyboards turned on in Settings. Here's how:
  1. With the keyboard open, long press on the globe or the emoji symbol if you have the emoji keyboard activated. A simple tap won't work because this brings up emoji or other keyboard options.
  2. At the bottom of the display, there are three keyboard options: shifted left, centered, and shifted right. Choose right or left to pick one of the one-handed keyboards.
With the one-handed keyboard enabled, the keys are shifted to the left or right by about an inch on the iPhone 7 Plus. The keys remain off-center for as long as you're using the keyboard, unless you tap the large white arrow.

Tapping on that arrow returns the keyboard to its standard center position, and you'll need to repeat the above steps to get it to shift over again.


If you don't have multiple keyboards set up, you'll need to either turn on another keyboard by navigating to the Keyboards option within the General section of your Settings app or manually turn on one-handed keyboard to the left or right on that same page.

Article Link: How to Use the New One-Handed Keyboard in iOS 11
 

GreyOS

macrumors 68040
Apr 12, 2012
3,264
1,549
0
Article could clarify that it’s available on the 4.7” phones too, but not if you have Zoom mode enabled
 
  • Like
Reactions: needfx

MrGimper

macrumors 603
Sep 22, 2012
6,092
6,312
0
Andover, UK
Article could clarify that it’s available on the 4.7” phones too, but not if you have Zoom mode enabled
Thanks for the heads up. I thought it should be available on the 4.7 too but it wasn't showing on my wife's 6s. However, she has zoom mode enabled, so that explains it
 
  • Like
Reactions: needfx

Westside guy

macrumors 603
Speaking of keyboards... is there a way to get the landscape keyboard on the non-Plus devices (like my 6S) to actually span the width of the screen? With iOS 11, in landscape mode there is blank gray space to the left and to the right of the keyboard - resulting in 25-30% empty, wasted space.
 

dtb200

macrumors newbie
Oct 28, 2016
13
25
0
I can't see it on my 6s even though i don't have Zoom mode enabled..?
 

WildCowboy

Administrator/Editor
Staff member
Jan 20, 2005
16,675
967
0
Thanks, folks...we added a clarification on the models it works with.

Seeing some reports from 6s owners that it doesn't work even with zoom turned off. (Like the post above this one. :))

I don't think we have a 6s among our staff members to test on, so would appreciate any other reports.
 
  • Like
Reactions: dtb200

Westside guy

macrumors 603
I can't see it on my 6s even though i don't have Zoom mode enabled..?
On the non-Plus devices, it looks like you have to go into the keyboard settings and manually enable it. And you have to pick either "left" or "right".

AND if you turn it on, then go back to fullscreen using the keyboard arrow - if you want it back later, you have to go back into Settings!

What happened to the company that used to say "you don't need a manual because everything is simply intuitive"?
 

GreyOS

macrumors 68040
Apr 12, 2012
3,264
1,549
0
On the non-Plus devices, it looks like you have to go into the keyboard settings and manually enable it on these devices. And you have to pick either "left" or "right".

AND if you turn it on, then go back to fullscreen using the keyboard arrow - if you want it back, you have to go back into Settings!

What happened to the company that used to say "you don't need a manual because everything is simply intuitive"?
Not the case on my 6. Works without a hitch from the keyboard without ever needing to go into settings.
 

WildCowboy

Administrator/Editor
Staff member
Jan 20, 2005
16,675
967
0
Okay, I think the issue is that you have to have multiple keyboards turned on. That gives you the globe/emoji key where you can activate the one-handed keyboard right from the keyboard. Otherwise you have to go into Settings.
 

dtb200

macrumors newbie
Oct 28, 2016
13
25
0
Could there be a difference between iOS 11 across different countries? I'm in the UK
 

0098386

Suspended
Jan 18, 2005
21,553
2,886
0
That’s actually really useful! Works just fine on my iPhone 6, but I’ll be replacing it with an 8 soon.
 

GreyOS

macrumors 68040
Apr 12, 2012
3,264
1,549
0
Er pretty sure you have zoom mode enabled, contrary to your earlier post.

Go to Settings > Display & Brightness > setting at the bottom

Yes - it's a screen recording of what happens on my 6s when I look for the one-handed typing option
 

James Candelo

macrumors newbie
Sep 20, 2017
2
1
0
USA
Speaking of keyboards... is there a way to get the landscape keyboard on the non-Plus devices (like my 6S) to actually span the width of the screen? With iOS 11, in landscape mode there is blank gray space to the left and to the right of the keyboard - resulting in 25-30% empty, wasted space.
I've been wondering the same, it is a total waste of space and even worse you end up tapping other keys. iOS10 had that right.
 

szw-mapple fan

macrumors 68000
Jul 28, 2012
1,561
1,008
0
Thanks, folks...we added a clarification on the models it works with.

Seeing some reports from 6s owners that it doesn't work even with zoom turned off. (Like the post above this one. :))

I don't think we have a 6s among our staff members to test on, so would appreciate any other reports.
Non-plus 6s owner here. It works perfectly fine, but it is disabled when I enter zoomed display mode. Hope this helps.
 

danskin

macrumors member
Feb 22, 2013
56
61
0
Anyone else hitting the 'keyboard settings' accentually and got taken away from what you are doing ? :(
Also apple why you no let me hide the one handed keyboards......I seriously don't need them.
 

C DM

macrumors Sandy Bridge
Oct 17, 2011
47,191
15,844
0
Anyone else hitting the 'keyboard settings' accentually and got taken away from what you are doing ? :(
Also apple why you no let me hide the one handed keyboards......I seriously don't need them.
Don’t enable the one handed keyboard and you won’t have it.