How to use xbackup properly

Discussion in 'Jailbreaks and iOS Hacks' started by hasek3139, Jun 13, 2011.

  1. hasek3139 macrumors 6502

    Joined:
    Mar 4, 2009
    #1
    I tried using xbackup to restore my JB apps.

    I followed the original directions, i launched the app , backed up, then sync with itunes, then restored phone from back up, jail broke, downloaded xbackup and there was nothing in the restore tab.

    did i miss a step?

    thanks
     
  2. soco macrumors 68030

    soco

    Joined:
    Dec 14, 2009
    Location:
    Yardley, PA
    #2
    I'm just going off of memory here, but I think you need to create the backup, then use something like iFile to dig into the folder where the 3 backup files are stored, email them (or something) to yourself.

    Then, after the re-jailbreak, you re-download xBackup, drop the files back into the folder, and restore.

    You probably missed that.
    I know I did a few times ;)
     
  3. Beatbeckham macrumors regular

    Joined:
    Feb 23, 2011
    Location:
    Norway
    #3
    Can you plz tell me where the folder is, and which 3 files?
     
  4. Jason B macrumors regular

    Joined:
    May 21, 2010
    #4
    Yea, I think your right. Because I did what the first poster said, and the backup wasn't there after the update! The instructions say it will remember it, but mine was gone and deleted. Luckily, i saved the backup to my desktop using iphone browser before hand, and then I dropped them back into the folder after updating.
     
  5. hasek3139 thread starter macrumors 6502

    Joined:
    Mar 4, 2009
    #5
    i trued using cyber duck and SSH but found no xcydia backup file, idk if i wanna buy ifile for $4 ill prolly just end of re downloading every JB app
     
  6. hasek3139 thread starter macrumors 6502

    Joined:
    Mar 4, 2009
    #6
    so i got a free trial for ifile and emailed myself the backups for xbackup, but how do i put the backups from the computer back into xbackup
     
  7. Jonk1183 macrumors regular

    Joined:
    May 31, 2011
    #7
    i had the same problem, nothing happened after the restore, i kept doing it and it eventually worked and i did not use ifile or cyberduck. just buggy i guess...
     
  8. milbournosphere macrumors 6502a

    milbournosphere

    Joined:
    Mar 3, 2009
    Location:
    San Diego, CA
    #8
    This thread is old, but I was finally getting around to updating my iPad to 5.1.1 and I came across this problem; I thought it'd be worth posting my solution to save future headaches. What I did was install xBackup, and then take a backup of Cydia. This backup file is located at /var/mobile/xBackup/Backups on the iPad. I have Terminal installed on my iPad, so I used the following scp command to send it to my home directory on my mac (no file browser required!):

    Code:
    scp /var/mobile/xBackup/Backups/backup.bk.zip userName@hostname:/Users/userName
    After jailbreaking, open up Cydia and install xBackup and OpenSSH. CD to the directory holding the backup file and use this scp command from your mac:

    Code:
    scp backup.bk.zip root@IP_Addr_Of_iPad:/var/mobile/Library/xBackup/Backups
    Then open up xBackups, go to restore, and it should find your backup file and go to work. Everything was restored just as I had left it. Well worth the $1.50!
     

Share This Page