How's your HD4890 keeping up?

Discussion in 'Mac Pro' started by sOwL, Mar 16, 2012.

  1. sOwL macrumors 6502

    sOwL

    Joined:
    Sep 25, 2007
    Location:
    Nerd Cave
    #1
    Hello everyone. I just thought I'd ask this question to everyone who's using a flashed HD4890 on their mac pro. Does it still work? QE_CI patches stopped working for me after 10.6.3 and i had to manually reinstall the kexts from 10.6.3 when upgraded to .4, .5 and .6. Upgrading to 10.6.7 renders my method useless. Netka's patches only work halfly (i do get my wallpaper etc but no 3d support. Zeus states drivers aren't installed). Thinking of upgrading to Lion, this could be a major reason to hold me back. I'm still on 10.6.6 with an edited plist to appear as 10.6.7 (for Xcode 4). How about your 4890? Is it still working fine?

    some info on my card:

    Sapphire HD4890 (New Edition) w/ Qimonda memory
    original rom md5 hash:
    AFAA8AB80D28B050B54923242CDF78F3
    rom patched with efi (currently on my card):
    59EB238CB978084AFFF5CEF729A2DA21

    The patched efi is the same as the one used by peloche and mfka. Im curious as to how it works for you guys. Running on a MacPro1,1 early 2007
     
  2. Mackilroy macrumors 68040

    Mackilroy

    Joined:
    Jun 29, 2006
    #2
    I don't use my 4890 in my Mac Pro anymore, but it did work even after 10.6.3. Got all the way to 10.6.8 with no issues...
     
  3. sOwL thread starter macrumors 6502

    sOwL

    Joined:
    Sep 25, 2007
    Location:
    Nerd Cave
    #3
    Which 4890 did you use? Mine stopped liking netkas drivers ever since the 10.6.4 graphics update. This is an excellent card and the best option i have for this mac would be the 5770 which apart from dx11 is worse than the 4890. Anyway, even just out of curiosity I'd love to hear what did the rest of the flashers do with their card
     
  4. Mackilroy macrumors 68040

    Mackilroy

    Joined:
    Jun 29, 2006
    #4
    I have an HIS 4890 - bought it after seeing five or six other people have success with it. It also works in my hackintosh, FWIW.
     
  5. sOwL thread starter macrumors 6502

    sOwL

    Joined:
    Sep 25, 2007
    Location:
    Nerd Cave
    #5
    I see. Well I got myself a 500gb HDD and installed Lion on it. I took it from a friend so yeah it's "illegal" but that's only for tests and will I ever decide to upgrade to Lion I will be buying it. So, after installing Lion and updating to 10.7.3, I downloaded netka's patch (Zeus only had 10.7.1) and again the same story. More stuff are supported now, but I'm still getting tearing and no 3d. That sucks, I guess my card is pretty much stuck in 10.6.6 with the 10.6.3 kexts.. I'd like to hear from someone that has the exact same card with me, if anyone is following the forum
     
  6. Tutor macrumors 65816

    Tutor

    Joined:
    Jun 25, 2009
    Location:
    Home of the Birmingham Civil Rights Institute
    #6
    Got 8 of them in systems ranging from 2007 Mac Pro 2.1 forward to Hacs and they all work great in SL and Lion.
     
  7. lannister80 macrumors 6502

    lannister80

    Joined:
    Apr 7, 2009
    Location:
    Chicagoland
    #7
    A little OT, but my XFX 4870 1GB still works great under Lion.

    Reference card FTW! Boot screen and everything, not kexts necessary!
     

Share This Page