HP 3330 vs Leopard

Discussion in 'Mac Accessories' started by Raptorsj, Feb 14, 2008.

  1. Raptorsj macrumors newbie

    Joined:
    Feb 14, 2008
    #1
    I am running OS X 10.5.1 on an iMac, and have an HP AIO 3330 using JetDirect. Worked fine under 10.4 but gives a "trouble communicating" error under 10.5. The AIO works as I can print from my 10.4 MacBook thru airport. I tried a search but had newbie luck (none). HP is a complete joke: "I can connect you to tech support and they will tell you if the driver needs to be replaced. That will be $39.00."

    Has anyone encountered this? I'm tempted to pound the crap out of the HP and move to Lexmark or some other mfr.

    Thanks for any assistance.
     
  2. MacUserSince87 macrumors member

    Joined:
    Aug 18, 2007
    Location:
    Northern Virginia, USA
    #2
  3. Raptorsj thread starter macrumors newbie

    Joined:
    Feb 14, 2008
    #3
    Printer reset

    MU: Many thanks. I did do that. However, the answer seems to have been to Reset the Printer.

    Mac support Article: 301185

    Interestingly, the System Profiler shows the same Printer driver as before the driver download. I will try to determine why the download doesn't appear to have worked, since the HP site shows the Driver Version is 7.8.0.61 (January 28, 2008) and the System Profiler indicates Driver Version 1.5.

    Thanks again for your help.
     
  4. Greg61 macrumors newbie

    Joined:
    Jul 23, 2007
    #4
    HP does NOT support the scanner driver for 10.5

    Hi,

    Same issue here: Printer works great (as does fax/copier). But, no Twain driver for scanner on 10.5. I emailed HP about this. This was their response:

    Thank you for contacting Hewlett-Packard.



    This is in response to your e-mail regarding the HP LaserJet 3300 Multifunction Printer.



    Greg unfortunately the LJ 3330 is not fully compatible with Mac OS 10.5 since Leopard does not support the type of file that is used on the Installer (Vixe installer), in this OS you will be able to print but the scan feature won't work. If you need an All in One printer for Leopard we recommend you the HP LaserJet 3050, LaserJet 3055 or LaserJet M1522nf since they are similar models to the 3330.
    We truly apologies for any inconvenience that this situation could cause you.



    Sincerely,

    HP Email Support

    ---------------------------------

    In other words, HP will not redo their installer to work on 10.5. How kind of them to offer up other models for me to buy when my current 3330 works just fine. I told them I'd be buying a Brother the next go around. A far less desirable solution was to load the HP software onto my work PC using the most up to date driver CD, which is Version 4.1 released in 2002. By the way on the CD itself it says it supports Windows 9X, 2000, ME XP and NT 4.0 as well as Mac 8, 9 AND X. Don't assume "X" goes all the through 10.5 if you ever get HP on the phone.

    I've bought my last HP device. Too bad. I have nothing but praise for every other function on the device.
     

Share This Page