HP C4385 Wireless Issues

Discussion in 'Mac Accessories' started by TheRealDom, Jul 6, 2008.

  1. TheRealDom macrumors newbie

    Joined:
    Jul 6, 2008
    #1
    I recently purchased an HP C4385 All-in-one wireless printer from Apple with a new MacBook. I have setup the printer per the instructions with new drivers downloaded from the HP site, but cannot seem to get it to print properly through its wireless connection. I have it setup & connected wirelessly, as the blue wireless light comes on in the front, and I can access its web server through a Web browser such as Safari at its address 192.168.2.4... It also shows up correctly when I attempt to add a printer as both a "Network Printer" and a Bonjour Printer. Setting up as "Network Printer", it automatically finds the "HP C4380 Series" driver, and sets up properly. When I print to it though, nothing ever happens. Using the Bonjour driver, the setup is smooth as well, and when printing using this type of driver, the queue opens, says it's printing, gets about 25% done, and then says the printer is idle. The printer itself never budges. If I connect o the printer via USB the printer prints properly. Has anyone else experienced this sort of maddening weirdness?!? :mad:
     
  2. Dolina macrumors newbie

    Joined:
    Jul 19, 2008
    #2
    Almost the same... but not.

    I too have that problem, only mine stopped at 21%. I've since re-installed my printer software, TWICE. Fun, right? Well, now my problem is that it won't connect wirelessly in the printer install program. "Failed to retrieve IP." Is it's favorite saying. However, it does tell me that it was successfully connected to my wireless network. WTF?! :confused: For emergency sake, the USB connection will have to work for now. So much for mobile printing anymore. ...It all started when Mac wanted to upgrade my HP Software along with Leopard. No more upgrades for me.:mad::mad::mad:

    Update: I can connect to another network on our router, however it's not the right network. I may have a router problem. Any suggestions?
     

Share This Page