HP DeskJet 810C is printing out garbage

Discussion in 'Mac Accessories' started by TheFoe92, Apr 7, 2010.

  1. TheFoe92 macrumors newbie

    Joined:
    Apr 7, 2010
    #1
    Initially, I had my WinXP computer share the printer with my Mac; it was connected to the PC, and through the wireless network, I would print off of my Mac. It used the hpijs driver. Everything worked fine. After the PC died, I decided that, until I get a new printer, I would use direct USB connection when I would need to print. However, after trying to add the printer from the Print and Fax tab, the printer spits out garbage.

    I tried the Gutenprint 5.2.5 driver for HP DeskJet 810C, and after having absolutely no luck with that, I went to check what driver I used to use when my printer was being shared, as it was printing properly back then.

    The result with the hpijs driver? Same garbage! It works fine when I use my Boot Camp, so it must be a driver problem with Mac OS X. I then tried the Generic PCL Laser Printer and the Generic PostScript Printer, but with the same results.

    What's going on? Why is nothing working on my Mac? It seems to works on the Windows computers in the house. I'm using the same cable. Any ideas as to what is causing this? Maybe it's a bug with the recent update...?

    In case it's of any use, I have Mac OS X 10.6.3 with a 2.8 GHz processor and 4GB of RAM.

     
  2. TheFoe92 thread starter macrumors newbie

    Joined:
    Apr 7, 2010
    #2
  3. gsahli macrumors 6502a

    gsahli

    Joined:
    Jun 1, 2007
    Location:
    Chicago
    #3
    Can you give me more detail about what you've done with Print & Fax? Have you deleted all previous instances of the printer? Does it show up in the Default window and then you select/add it? Have you tried resetting the Print System?
    http://support.apple.com/kb/HT1341

    Did you install all 3 parts of hpijs?

    In case your USB driver (part of CUPS) is broken, try installing usbtb:
    http://buymelunch.org/printing/usbtb/
     
  4. TheFoe92 thread starter macrumors newbie

    Joined:
    Apr 7, 2010
    #4
    I have tried everything within the limits of my knowledge.

    More specifically, I have tried reassigning the printer's drivers several times, including the hpijs, Gutenprint, and the recently downloaded usbtb.

    If, by three parts, you mean Foomatic, hpijs, and Ghostscript, then yes, I have installed all parts of hpijs.

    I have also tried to reset the print system.

    All of this with no luck...

    I'm starting to wonder whether or not it is even worth expending this much energy on this junk. Of course, it would be great to have basic functionality, at least for a few more weeks.
     
  5. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #5
    My recommendation to you is to chill. CUPS is an integral part of MacOS X. It is, in fact, owned by Apple. Your printer is supported by Gutenprint which you have installed. Your printer should now just work. The fact that it does not means that something unusual is afoot.

    Floundering around will not fix the problem. You must be systematic. Check out your computer's browser-based CUPS page. However, you should not change anything that you don't understand. You should also download and run Print Therapy 7.x. It may be able to identify problems with your particular setup.
     

Share This Page