HP LaserJet 6 MP and Mountain Lion

Discussion in 'Mac Basics and Help' started by RAMtheSSD, Mar 26, 2013.

  1. RAMtheSSD macrumors member


    Mar 23, 2013
    High on a Mountain Looking for Wisdom
    I have been going crazy trying to get this to work so now, I am asking for help; I hope someone here has had this problem and solved it. HP says that the 6MP is compatible with Mountain Lion, Apple says the 6MP is compatible with Mountain Lion -BUT- I can not print anything correctly and when it does print, it prints as if it was printing a photo of the page and generally cuts off the right edge. This, even though the margin settings are correct for 8 1/2 by 11 paper. I didn't just rely on software update, I went to HP and got the driver install image and this went off without a hitch.

    It works from windows 7 with no problems so far (still testing, looking for a clue as to what could be the problem because it does not make sense that I can do anything with windows that I cannot with a Mac) but I would much rather print from Mountain Lion rather than reboot my Mac Pro -it will not print from a VMWare Fusion virtual machine.

    I have the parallel to USB cable from Prolific (the name on the cable is something else but those are the people who made it) and I can see the printer (it even shows the correct picture) but no printing ever happens. I have the correct kext installed.

    I tried making my MBP (for convenience) a windows server and then printing through sharing and, in the sense that everything went well in the setup, it worked. Then, I tried to print and the printer was essentially permanently paused; I would click on resume and it would instantly go back to paused. Tried printing from MBP + Windows directly, no problem, the printer works fine.

    I am considering a solution that was suggested elsewhere involving a wireless connection through a wireless router which, if successful, would allow me to print from anywhere -including from my iPhone! but I am concerned that if the problem is in the OS (and I have seen nothing to suggest otherwise) this would be a waste of money and time.

    I have come to consider using a Raspberry pi as a printer server but I fail to see how one form of CUPS could print to it when another can't

    I am out of ideas. I love this printer and worst comes to worst, I will reboot. At less than a cent per page and for someone who's needs are essentially B/W and High Res with high readability, there is no need to change and I do not think they make printers like this anymore. Thus, barring things like "get a new printer" any ideas are welcomed.
  2. jekyl macrumors 6502


    Mar 6, 2011
    I have a Laserjet 4MP. I bought a cheap print server that connects directly from the 36pin port on the printer to my router and that works perfectly printing both from Mountain Lion and Windows7. I experienced a world of pain printing to that printer through a USB adapter from my Macs however.
  3. benwiggy macrumors 68020

    Jun 15, 2012
    Your print supports PostScript, so should work fine with a "Generic" PostScript PPD, without the HP drivers.
    I found some of the newer HP drivers to be really shocking and cause all sorts of problems with my 5100.

    However, the latest drivers come from Apple's website, not HP's. (Though HP still writes them.)

    Alternatively, you can access a lot of controls for your printer through the CUPS web interface. This may need turning on with the following Terminal command:
    cupsctl WebInterface=yes
    Then you just go to the following local URL in a browser: http://localhost:631

    Then check the Print queue's settings/options there.
  4. RAMtheSSD thread starter macrumors member


    Mar 23, 2013
    High on a Mountain Looking for Wisdom
    Did CUPS All Day...

    Benwiggy, I have tried everything in CUPS that I could find. There can be no doubt that your suggestion has made this a whole lot easier than it would have been otherwise -I was still command lining everything; however, while it printed fine just afterwards, it went right back offline. Within a minute or so after the test job it refused to print anything again. However, again, thanks because the web interface is a hell of a lot better than the command line :)

    Jekyl: What was the brand name and the model of the adapter? Is it wired or wireless? Do you have the connection going to a switch, a router, or directly into the Mac Pro so that the machine is acting as a router? I have been looking at this other adapter (http://http://hawkingtech.com/products/hawking_products/print_servers/HPS1P.html) while I was very excited at first -because it would seem to have worked for someone else- when I wrote their tech support and specifically mentioned Mountain Lion and 10.8.3 -both so no way of making a mistake- they sent me back a reply for Leopard!

    I haven't had a chance to write them back but I will if only because being able to print from my phone instantly to my home printer from anywhere sounds just err Insanely Great :)

Share This Page