HP Officejet 5600 series printers

Discussion in 'macOS' started by SponPlague, Aug 28, 2009.

  1. SponPlague macrumors newbie

    Joined:
    Sep 22, 2008
    #1
    Hi, folks: http://www.google.com/search?client=safari&rls=en&q=snow+leopard+officejet&ie=UTF-8&oe=UTF-8 says the HP Officejet 5600 series (I have a 5615) is supported, but after choosing download and install, and accepting the license agreement, I gather the download can't be found. Have HP made a mistake on their webpage? (Telephone support in Canada doesn't know).

    Can anyone offer advice or help, apart from "now is the time to test your time machine"?
     
  2. ProfChips macrumors newbie

    Joined:
    Aug 28, 2009
    #2
    I am having the exact same problem. I have the HP OfficeJet 5610xi all-in-one. It worked fine under 10.5, but broke with 10.6. It should be the "HP Officejet 5600 series" driver.

    I'm getting the same error where it wants to download via software update, but then I get the message:

    The software is currently unavailable.
    You can check for the software later by choosing Software Update from the Apple menu.

    If I go manually into the "add printer" interface, both the Officejet 5600 series "usb multifunction" is shown as well as the "Officejet 5600 series [XXXXX] (fax)." If I load the FAX one, I can scan. But printing sends the print job into etherzone. It just never prints, though the print queue will look like the job successfully printer. weird! electing the 5600 series just plain does NOT print.

    Should we wait a few days? I noticed HP says that support is supposed to be within Snow Leopard. As shown here:



    grr. I really can't deal without printing. It's not like this printer is ancient or anything. It's only a couple years old.

    :(

    p.s. if you go to http://support.apple.com/kb/HT3669 you will see that our printers are not listed! The pulldown says the following:

    If your printer or scanner does not appear in the list below, visit the device manufacturer's web site or contact the manufacturer to find out if software is available for Mac OS X v10.6. If software for your printer is not available and your printer supports a common printer language such as PostScript or PCL, you may be able to perform basic printing functions using the Generic PostScript or PCL drivers available from the "Print Using" pop-up menu while adding a printer.

    Well, I couldn't get the above to work.
     
  3. ProfChips macrumors newbie

    Joined:
    Aug 28, 2009
    #3
    Got it!

    Here's the scoop. After hours trying and retrying the HP driver. I did what HP told us NOT to do. I just could NOT go weeks without printing capability.

    I went to HP and re-downloaded the HP driver set for the 5600 series that is for leopard. After the 120+ file downloads, I mounted it and installed. wala! the printer is back and it works fine. Apparently the problem is with Snow Leopard. Here's a link for you to use for the 5600 series driver:

    http://h10025.www1.hp.com/ewfrf/wc/softwareList?os=219&lc=en&dlc=en&cc=us&product=441125&lang=en

    then select the first driver under the 'info file' for 10.6.

    Once you've downloaded the package file, double-click to mount and install. You shouldn't even have to reboot. I didn't. The printer will show up in your print & fax list. Select it as your default and you should be done. :)
     
  4. SponPlague thread starter macrumors newbie

    Joined:
    Sep 22, 2008

Share This Page