HP Photosmart "maybe" problem??

Discussion in 'Mac Accessories' started by clickey-grl, Oct 17, 2009.

  1. clickey-grl macrumors newbie

    Joined:
    Jun 11, 2009
    #1
    :eek:Hello all, so I have an old printer (HP Photosmart C4180) and I never installed it on my imac using the cd it came with (I assume it has an version on instalation). And I installed what I believe it works for my printer (I did typed the version of my printer from the HP.com website). So I installed the one that says that it works for Mac OS X v10.3.9, v10.4 and v10.5 (mine is 10.5.8).

    So I install and follow the instructions and on one of the steps it says that I have to SELECT THE DRIVE MODEL and when I look down it says PHOTOSMART C4100 SERIES (I think it's trying to say that my printer is from the 4100 series...is that right???)

    So I choose the PHOTOSMART C4100 SERIES and continue the steps and when I click on INSTALL it asks me that: HP installer requires that you type your password.

    Should I type my password?
    Is this something that will always show up everytime I want to install something new?

    Like, I want to install "The Unarchiver" and it always ask me to put my password in order to install it...

    What should I do?
     
  2. scottkifnw macrumors regular

    scottkifnw

    Joined:
    Jan 17, 2008
    Location:
    Trophy Club, TX
    #2
    yes

    type in your administrator password and it should load right up.
     
  3. clickey-grl thread starter macrumors newbie

    Joined:
    Jun 11, 2009

Share This Page