HP Printing Problem with Leopard--Solution!

Discussion in 'Mac Basics and Help' started by rellik75, Nov 2, 2007.

  1. rellik75 macrumors newbie

    Joined:
    Nov 2, 2007
    #1
    Hi Everyone!!

    I'm brand new to this forum and brand new to the mac world. I've just gotten my new 24" 2.8 iMac and love the thing. It's just beautiful to look at and and dream to use. Although coming from the windows world, I've got a ton to learn

    Anyway...I wanted to start off by posting a solution I figured out to those who's apps may be crashing when trying to print under Leopard. I've got an HP Officejet 7310 connected to my network. When I initially turned on my imac and configured the HP printer it was using Bonjour (which I have no clue what it does). Anyway...I downloaded the HP drivers which added all my scan and fax functionality--good stuff. When I tried to print in Firefox, it would crash. Then I tried Safari..crash there too. I tried Preview...again--crash. I went in to my printer options, deleted the printer, and then started the process to add a new printer. Instead of using Bonjour, I told it to use IP communication. It found my HP and configured it. I tried to print a test page and PRESTO!!! It worked...

    So for anyone who's having printing issues, change the configuration to use IP communication instead of Bonjour.

    Hope that helps!!!!

    Cheers!
    Wayne
     
  2. elroy66 macrumors newbie

    Joined:
    Feb 10, 2009
    #2
    HP Officejet 7310

    ..don't know what happened!

    ... and I couldn't figure how to make it print backwards so that the top sheet printed last.

    Any ideas?

    Thanks

    elroy
     
  3. elroy66 macrumors newbie

    Joined:
    Feb 10, 2009
    #3
    Officejet 7310

    Wayne -

    Where did you find the drivers? The HP site doesn't show any drivers compatible with the Macintosh system.

    Thanks

    Elroy
     
  4. rdowns macrumors Penryn

    rdowns

    Joined:
    Jul 11, 2003
    #4
    Um, Elroy, this thread is from November 2007.
     
  5. simonhulse macrumors newbie

    Joined:
    Jul 29, 2009
    #5
    No solution. Actually drivers only support 10.4

    I have just spoken to the kindly folks at HP and they inform me that the 2300 drivers are only compatible with Mac OS up to 10.4. In particular, 10.5 is not supported.

    If you look at their downloads web page you will see that the most recent set of drivers was released in 2003. HP tell me that they will be updating the drivers to support 10.5 but they have no idea when this will happen because the printer is such an old model. Put more simply: you are screwed until we get round to it but can't tell you when that will be.

    Actually my problem is a bit different from what you guys had. I can print from Omnigraffle, Safari and Preview to my 2300dn. However, when I try to print from MS-Office, Eudora, Filemaker or Textedit the application quits the moment I hit the print button in the print dialog box. Lovely! And I thought it was me. Indeed, I went through the following before getting round to calling HP:
    – Reinstallation of OSX 10.5
    – Fixing all permissions on my hard disk
    – Reinstalling the HP printer drivers
    – Reinstalling MS-Office

    Of course what makes me really mad is that as part of the 10.5 re-installation I wiped all my data. you know how it is you are a bit cross and trying to get others things done because the bloody printer won't behave and you don't concentrate sufficiently on the installation dialog boxes... Not disastrous because I was backed up. The back was 6 days ago and I've only lost a bit of data but even so...grrrgnnnhhhhh!!!!

    I waited for more than a year to upgrade from 10.4 to 10.5 to avoid most of these terrors – clearly I did not wait long enough. I do have an Epson 1290 which seems to work fine under 10.5 but the 2300dn is (has been?) my main workhorse.

    The result: A huge black mark for HP, and I think I'm going to send them to the naughty step for quite a while. Actually, I'm pretty mad about it all because 10.5 was released in October nearly 22 months ago and the 2300 series was part of the core printer range.
     
  6. simonhulse macrumors newbie

    Joined:
    Jul 29, 2009
    #6
    HP2300Dn with Leopard 10.5

    I tried the Gutenprint drivers – and they worked fine!! See the following web address:

    http://gimp-print.sourceforge.net/MacOSX.php

    Hope this works for anyone else having the same problems.
     

Share This Page