HTML in quote/edit box.

Discussion in 'Site and Forum Feedback' started by UltraNEO*, Jun 24, 2009.

  1. UltraNEO* macrumors 601

    UltraNEO*

    Joined:
    Jun 16, 2007
    Location:
    近畿日本
    #1
    Recently, I've been seeing HTML in the comment box, most visible when i'm quoting someone (see attachment), clicking on the icon doesn't seem to do anything, actually it doesn't appear to be active At first I thought it's my browser but after a restart it's still doing the same thing.
     

    Attached Files:

  2. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #2
    How often do you see it? It's possible the person tried to put in HTML them self not realizing it wasn't accepted and they were suppose to use the vB Code markup.

    I also see in the pic that text under the text box saying "You have selected 2 post(s) that are not part of this thread. ...." That would be related. How did you quote the post?
     
  3. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #3
    It's just you, unless that user removed the HTML from the post.
     

    Attached Files:

  4. Doctor Q Administrator

    Doctor Q

    Staff Member

    Joined:
    Sep 19, 2002
    Location:
    Los Angeles
    #4
    You can type HTML tags in a post, but the HTML won't be "processed". It'll be treated simply as regular text. We have purposely disabled the use of HTML since it would not be safe. Markup must use vBulletin tags. If you see HTML in a post, it may be the result of somebody copying/pasting from elsewhere. If they notice that the markup doesn't work they will probably remove the tags or switch them to vBulletin markup.


    Tip for all users: Putting HTML in posts

    If you want to mark up your text (bold, lists, etc.), use the markup icons as you type your post, or type vBulletin tags directly. Don't use HTML tags since they will display as part of the text, e.g.,
    This <strong>word</strong> isn't bold.

    The <br /> tag doesn't cause a linebreak.​

    If you want to display HTML source code in your post, you can use the
    HTML:
     tag to preserve spacing, highlight tags, and show it with a monospaced font, e.g.,
    [INDENT]Hey, everyone, my HTML checker says I have two mismatched tags.  Can someone help me find the problem?  Here's my web page:
    [HTML]The following are <strong>very important</em> instructions:
    <ol>
        <li>Read these instructions.</li>
        <li>Follow these instructions.</li>
    </ul>
    [/INDENT]
    The
    Code:
     tag is the same, without the color coding:
    [INDENT]Hey, everyone, my HTML checker says I have two mismatched tags.  Can someone help me find the problem?  Here's my web page:
    [code]The following are <strong>very important</em> instructions:
    <ol>
        <li>Read these instructions.</li>
        <li>Follow these instructions.</li>
    </ul>
    [/INDENT]
     

Share This Page