HTTPS Problem with Safari 5.1

Kyahx

macrumors newbie
Original poster
Apr 21, 2011
27
0
Has anyone else had a problem with HTTPS sites in Safari 5.1? I can't get any secure sites to load, been having to use Chrome for the past week :/

Same error not matter what site I try to browse to.

"Safari can't open the page "https://www.facebook.com" because Safari can't establish a secure connection to the server "www.facebook.com".
 

mrapplegate

macrumors 68030
Feb 26, 2011
2,818
8
Cincinnati, OH
Has anyone else had a problem with HTTPS sites in Safari 5.1? I can't get any secure sites to load, been having to use Chrome for the past week :/

Same error not matter what site I try to browse to.

"Safari can't open the page "https://www.facebook.com" because Safari can't establish a secure connection to the server "www.facebook.com".
Not a problem here. Empty your cache, maybe. Try Resetting Safari.
 

throttlemeister

macrumors 6502a
Mar 31, 2009
527
38
Netherlands
I don't know if you still have the problem, but I had the same thing happening and I fixed it by deleting:

~/Library/Preferences/com.apple.security.revocation.plist

For some reason, this file was generating access denied errors in console and removing it fix my Safari problems.
 

pslebow

macrumors newbie
Jun 11, 2012
1
0
HTTPS: slow loading on Safari - fix for me

While some recommended deleting:

~/Library/Preferences/com.apple.security.revocation.plist

No impact ....

So I deleted (renamed):

com.apple.security.plist

and suddenly https site loaded normally.

Go figure!

I'm sure it will appear again as a problem somewhere else
:(
 

PaulD19

macrumors newbie
Jul 8, 2012
1
0
Can anyone tell me where to find ~/Library/Preferences/com.apple.security.revocation.plist

so I can rename it as indicated above? I'm having the exact same issue, and have tried seemingly everything.
 

mjenks

macrumors newbie
Oct 17, 2011
16
0
HTTPS problems with both Safari 5.1 and Firefox

I'm having exactly the same problem, unable to access any https sites with any of my browsers. I also looked for the Library/Preferences file and couldn't find it. I'm in OSX Lion, on a MacBook Pro purchased new last year. Part of the problem--Apple discussion pages are https, so I can't do research there. Glad someone recently is having the same problem.

Has OSX Lion changed the location for these security files? Is this some nefarious scheme to have us delete our security protocols so our computers can be accessed? I've contacted my ISP and several of the sites themselves (gmail, for instance), but I'm guessing the problem is actually with SSL (which I don't completely understand).

I found references to PC users who had solved the same problem by opening port 443, which also seems dangerous. But I can't figure out how to do it, especially with only having access to half the internet.
 

mjenks

macrumors newbie
Oct 17, 2011
16
0
Solution

Just wanted to say that my problem was with my ISP. They reset my modem, and that seems to have fixed the problem, although they wanted to blame it on Mac OS. I did worry that there was something amiss with the security protocols on the Mac, so I was relieved. As usual, my Apple worry is unfounded.

I encourage you to contact your ISP.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.