HUGE permissions issues

Discussion in 'Mac OS X Server, Xserve, and Networking' started by disconap, Jun 17, 2014.

  1. disconap macrumors 68000

    disconap

    Joined:
    Oct 29, 2005
    Location:
    Portland, OR
    #1
    Hi all--I'm having a weird problem with permissions on my server (Mac Mini mid 2011 i5 2.3gHz, 8gbRAM, 10.9.3, Server 3.1.2). I'm running a RAID10 and RAID0 (both OSX software raid) connected via thunderbolt. The problem is that I seem to have to propagate permissions to the files in my drives like 3-4 times per week; the main drive tier retains the proper permissions when I go to check, but the files either can't be opened or copied. My user is set to a group that have full control permissions over the drives.

    Any thoughts? It's becoming really tiresome and is exactly the sort of thing I switched to OSX Server to avoid. It also makes using the drives for my itunes library a royal PITA, as iTunes keeps freezing, crashing, and then preventing me from copying files to the library until I change the permissions again...
     
  2. jamall macrumors regular

    Joined:
    Jun 9, 2003
    Location:
    Canberra, Australia
    #2
    Have you tried checking the "Ignore permissions on this drive" check box in the get info window, or is access control necessary?
     
  3. disconap thread starter macrumors 68000

    disconap

    Joined:
    Oct 29, 2005
    Location:
    Portland, OR
    #3
    Access control is necessary as I run a small company, and different drives/folder have different info and files (hence the group permissions)...
     

Share This Page