Huh? App Store won't load on Wifi but will on 3G

Discussion in 'iPhone Tips, Help and Troubleshooting' started by ying yang, Oct 11, 2008.

  1. ying yang macrumors regular

    Joined:
    Sep 18, 2006
    #1
    I haven't been able to load the App Store on my phone all day. I just restored it an hour ago and the first thing I did was check the store. When it opened I was asked for my Wifi info. While I was typing that the store loaded in the background. I finished typing and exited, thinking the restore fix it somehow. I then tried the Wifi Music Store and it loaded nothing. No content at all only the spinning circle thing. I went back into the App Store and it won't load again. I turned off Wifi went back in and it loads. Turned on Wifi again and it didn't load.

    What could be causing this?
     
  2. mlemonds macrumors 6502a

    mlemonds

    Joined:
    Apr 9, 2008
    Location:
    Lexington, KY
    #2
    are you able to browse the internet while on wifi?
     
  3. ying yang thread starter macrumors regular

    Joined:
    Sep 18, 2006
    #3
    Yeah.

    I was thinking it might be problem with m network but I've just checked everything that uses it (AppleTV, Xbox, this Mac obviously) and they're working fine. I reset my router and modem just for kicks but that didnt help with the phone issue.

    EDIT: The Youtube, weather, maps and stock apps are doing it now too. Mail and Safari are still working though.
    :confused:
     
  4. mlemonds macrumors 6502a

    mlemonds

    Joined:
    Apr 9, 2008
    Location:
    Lexington, KY
    #4
    just for kicks, remove the network from your iphone and then add it again. if that doesn't work i foresee another restore in your future
     
  5. ying yang thread starter macrumors regular

    Joined:
    Sep 18, 2006
    #5
    I did that and Weather loaded, Stocks loaded, the App Store loaded, but then the Wifi Store wouldn't. Then I went back into the App Store and it wouldn't load again.

    ???
     
  6. skerns macrumors newbie

    Joined:
    Jul 4, 2009
    #6
    Same problem here...

    I am having the same issue. App store won't load on wifi on my 3Gs but on my wife's 3Gs it works fine.
     
  7. skerns macrumors newbie

    Joined:
    Jul 4, 2009
    #7
    UPDATE: Airport Extreme Firmware could be problem

    I found a fix for my case anyway. I have two wireless networks at my house. One for work, one for personal. Both use an Apple Airport Extreme 802.11n base station. One has 7.4.1 firmware, the other 7.4.2. The 7.4.1 network allows me to load the app store over wifi, but the 7.4.2 does not. Everything else works fine, such as email, internet, etc. on the iPhones and various other devices in the house. The only thing I have trouble with is the App Store when connected to the 7.4.2 unit.
     

Share This Page