Hulu Plus Problems after 5.1 update

Discussion in 'Apple TV and Home Theater' started by frankdogg, Sep 25, 2012.

  1. frankdogg macrumors 6502


    Mar 24, 2011
    Mid-Wilshire LA
    What's up guys.

    After updating to 5.1, Hulu Plus fails to load the videos. I constantly get "an error occurred loading this content"

    I even tried restoring the ATV3

    Anyone else experiencing this? I need my Hulu. Any help would be greatly appreciated.
  2. frankdogg thread starter macrumors 6502


    Mar 24, 2011
    Mid-Wilshire LA
    solved the problem. i just downgraded the firmware back to 5.0.2.
  3. andrewbkillen macrumors newbie

    Sep 27, 2012
    I am experiencing this as well. I was just curious if anyone had a workaround other than downgrading the firmware.

  4. frankdogg thread starter macrumors 6502


    Mar 24, 2011
    Mid-Wilshire LA
    People are saying Ethernet is the prob and that using wifi fixes the problem
  5. cmcclure16 macrumors regular

    Sep 26, 2007
    I'm on 5.1 and I was able to watch 3 shows earlier today with no problems.
  6. HuskyMac macrumors newbie

    Apr 26, 2012
    Denver, co
    same problem here. happens with netflix too... ill have to try using just wifi when i get home today...very annoying.
  7. LMD75, Sep 29, 2012
    Last edited: Sep 29, 2012

    LMD75 macrumors 6502

    Oct 5, 2010
    Did you just download the older IPSW, connect to iTunes and did an SHIFT+Restore?

    I tried this an received an iTunes error 3194 and I think this is because they just stopped signing of the 5.0.2
  8. kamui macrumors newbie

    Jul 19, 2008
    Switching to wifi did fix the issue for me.
  9. bripab007 macrumors 6502a

    Oct 12, 2009
    Glad I found this thread; thought I was going insane.

    Just tried a bunch of things last night to no avail until I decided to try wi-fi for the heck of it. Lo and behold: it works.

    Since everything else on AppleTV appears to work without issue over ethernet, as best I can tell, I'd say this is an AppleTV-Hulu-5.1 update problem.

    But whadya bet Apple's no longer signing activations for the previous firmware if I try to downgrade today?
  10. ebnyc macrumors newbie

    Sep 28, 2012
    Same here. My ATV 3 has problems with Hulu, Photo Stream, iTunes Match using Ethernet. Netflix and iTunes Store okay. Now using WiFi connection, no issues at all. This all started after the latest iOS update. Definitely a software bug but Apple support was no help.
  11. rjstegbauer macrumors newbie

    Oct 1, 2012
    Re: Downgrading Apple TV3 Firmware

    OK. I'll bite.

    How do you downgrade the firmware on an Apple TV 3?

  12. frankdogg thread starter macrumors 6502


    Mar 24, 2011
    Mid-Wilshire LA
    yeah i think they stopped signing. try wifi, hopefully it fixes your problem.

    you would have to download a previous ipsw (5.0.2) and connect the ATV to your comp and shift restore using itunes. but it looks like apple is no longer signing for 5.0.2

    glad to hear!
  13. Tezcatlipoca macrumors regular


    May 23, 2012
    Cambridge, UK
    No Hulu in the UK, but I've had this problem with iTunes Match via Ethernet since the v5.1 update:

    Others have found that the problem also affects and more.

    Switching to WiFi has fixed it, as above.

    I did try contacting Apple support, and had the usual unhelpful responses that I have come to expect, in which the CSR ignores/misunderstands what I have already told them and just gives links to troubleshooting pages...

    I did find a thread at though where someone from Apple had actually posted and asked people for more info on their problem and network setup:

    royb @
  14. muchlove macrumors newbie

    Oct 1, 2012

    Thank you!
    That totally worked, went wireless and Hulu is back. odd.

  15. rjstegbauer macrumors newbie

    Oct 1, 2012
    Thank you for pointing me to this solution. Switching to Wi-Fi allowed me to play Hulu videos on my ATV3.

    The sad part of all this is that I called *Apple* and they had no idea how to help me. I had to come here to solve this problem!

    Thanks, MacRumors!!
  16. Rushli0n, Oct 10, 2012
    Last edited: Oct 11, 2012

    Rushli0n macrumors regular

    Aug 27, 2012
    So my ATV2 has always been on Wifi and this happens to me on both Hulu and Netflix. Hulu more so, but it appears to be navigation specific. When I try and launch a show from my queue persay, it fails. But if I launch it from recently watched its fine

    Anyone have a fix or experience this?
  17. zfoster13 macrumors member


    Apr 19, 2012
    Hulu Plus is really screwed up since the update. Sometimes I can watch everything no problem and other times I can't watch anything. I'm on wifi and never had this problem before the update. I have no problems with Hulu Plus on any other devices. They need to fix this soon!
  18. swwack91 macrumors 6502a

    Jan 28, 2007
    New Jersey
    I've had the same problem and have found the same solution. Hulu works perfectly over wifi but does not play videos on ethernet.

    This really needs to be addressed soon! :mad:
  19. Sean Dempsey macrumors 68000

    Sean Dempsey

    Aug 7, 2006
    Same deal.

    Doesn't anyone ever want to know WHY? I run gigabit Ethernet all over to a Aebs, and yet it doesn't work? Why are there never any networking answers?
  20. GoCubsGo macrumors Nehalem


    Feb 19, 2005
    I have been on 5.0.2 and on wifi; I've never connected via ethernet with my ATV. I have had issues with Hulu in the past where I get that error (both trying to watch from queue and recently watched) but not as much as I do now. I am in the middle of updating the software because I have had no joy with 5.0.2. I tried ethernet for kicks and same issues occurred. It is truly annoying.

Share This Page