Hung on blue screen after 10.5.6 update

Discussion in 'macOS' started by IdiddidI, Dec 31, 2008.

  1. IdiddidI macrumors member

    Joined:
    Jan 22, 2008
    #1
    I have just updated my iMac G5 to 10.5.6. When I restart, it hangs on the blue screen before log in. I have restarted in Safe Mode (no problem there) and removed the APE files in the library folder, as suggested on support.apple.com. I have also repaired permissions and verified the drive. Still no luck.

    Is it really possible that the computer needs hours to restart after the update?

    And would it be better for me to restore using Time Machine or do an Archive & Install with the Leopard discs? The computer was acting a little funky before I updated to 10.5.6 (iTunes was sluggish), but I never had a problem rebooting.
     
  2. Amdahl macrumors 65816

    Joined:
    Jul 28, 2004
    #2
    Time Machine is great because you get a free disk-defrag (if you Erase/format your drive), but you have the risk of losing any files you had Excluded from the backup. Any virtual machine files are highly likely to be included in this category, which may not be very likely on a G5.

    As for your hang, Apple discussions mention some Extensions being incompatible w/10.5.6. If that rings any bells with some hardware you've added, then you might know what the problem is or where to look for updates.
     
  3. confounded macrumors newbie

    Joined:
    Feb 28, 2009
    #3
    Perhaps this will help someone

    After suffering a "blue screen of death" on my Intel iMac a few days ago, I searched the internet for a cure, but found nothing which obviously matched my circumstances exactly. After deciding I wasn't brave enough to crack open an iMac and replace the hard drive (some people seemed to suggest the drive would be beyond saving) nor wanting the expense of someone doing it for me, I thought I'd post how I got out of it, as someone else may find it helpful. I should say that I'm not terribly technical so a lot of what appears on these forums goes over my head. Forgive me if that becomes obvious.

    I did go out and buy a new external drive to make the process easier, but I'd needed a bigger one anyway.

    I'd been running 10.5.6 without incident for a while, but I only do updates manually and am fairly sure I'd downloaded nothing from Apple for at least a week or so. As far as I know I had none of the third party software listed elsewhere as a possible cause.

    On 23 Feb, just before I went out for a while, I left the Mac to reboot. I was longer than I expected and a couple of hours later returned to find it apparently locked in the blue screen cycle other people have described. Nothing I tried would get it back. Zapping the PRAM didn't help. It wouldn't boot in safe mode, leaving it unplugged for half an hour didn't solve it and starting it up with verbose logging didn't help because at the point things went wrong, the screen went blank and I didn't have time to read it (and my attempt to take a photo of it at just the right time failed).

    I run my iMac with three equal partitions on the internal hard drive (a habit from system 9 days which had got me out of some fixes in the past), but I assume I could have done the following using an external drive instead of a second partition. I suppose you would have to go through installation one more time to get the operating system back on the internal drive...

    What I did:

    Rebooted with the system DVD. Then checked all the internal disc partitions with Disc Utilities (came up with nothing wrong) and repaired permissions on the original start up partition. (At this stage I attempted to reboot from the internal start up partition, but nothing had changed so reverted to the DVD).

    Installed the minimum of OSX on an external drive and rebooted, going through the registration stuff just to get it going. (Re-checked internal drive with Disc Utilities, but still nothing wrong found).

    I then backed up everything on the internal drive (though I also had it covered in time machine) and wiped one partition (not the one with my original system) to do a fresh installation.

    Then rebooted from the system DVD and installed yet again on the cleared partition. At the point when it asks if you want to transfer settings from another computer or drive, I chose to copy everything from the original operating system partition... takes a while.

    Rebooted with the new system and everything was much as it had been before the problem except with a different partition running the show. I'm not sure if this is necessary, but I then renamed the old partition with the old OS so I could rename the new one to what the old one was (i.e. partition 1 has now become partition 2 and vice versa). I assume this would help any aliases find what they were looking for and to stop Photoshop thinking it had been moved, for example.

    A nervous hour when I then did a complete software update and rebooted, rather expecting whatever problem I'd had would be replicated. Fortunately it wasn't. Put everything back on the partitions where I wanted it though I have retained the old system and library folders in case I find there is something I am missing.

    A few days later, everything seems to be as it was. I haven't needed to re-install any other software so far. My only problems were to lose a couple of custom Icons, and for some reason my external back up disc which time machine uses had become "read only" and I could find no way around this, so opted to reformat that and start again (there was nothing on there that I wanted which I hadn't by now backed up elsewhere and I assume my problem was stored on it too).

    This all cost me pretty much a day of my life, but forearmed with this, I could have been back to mindlessly gazing at this screen a whole lot quicker.
     

Share This Page