HW Accelerated Flash Slows Full Screen Video Playback

Discussion in 'MacBook Pro' started by oscar.lopez, Oct 16, 2010.

  1. oscar.lopez macrumors newbie

    Joined:
    Oct 16, 2010
    #1
    I noticed that all the flash videos played inside Safari on my MBP were slow and choppy when switching to full screen mode. This started happening after upgrading to Flash 10.1 r85. I disabled hardware acceleration on Flash's settings, and video playback went back to normal.

    What can I do to use hardware accelerated Flash, but without the slowdowns?
     
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #2
    What exact/specific MBP do you have? Maybe its GPU is not supported by the new Flash version.
     
  3. oscar.lopez thread starter macrumors newbie

    Joined:
    Oct 16, 2010
    #3
    It's a mid-2010 MBP, 15-in, 2.66GHz Core i7, 8GB, with Intel HD Graphics with 256MB of DDR3 SDRAM / NVIDIA GeForce GT 330M with 512MB of GDDR3
     
  4. kgeier82 macrumors 65816

    Joined:
    Feb 18, 2008
    #4
    Maybe for some reason it isnt switching from the intel gfx to the 330m for the flash video. Sounds about right to me. Check it out with gfxstatus
     
  5. Bill Gates macrumors 68020

    Bill Gates

    Joined:
    Jun 21, 2006
    Location:
    127.0.0.1
    #5
    It's a bug in the latest flash player. Manually switch to the Nvidia GPU for smooth playback.
     
  6. Raggy macrumors newbie

    Joined:
    Sep 1, 2010
    Location:
    London, UK
    #6
    Yes - what Mr Gates said. I did that before and it worked fine after. Machine seems to get very hot though - is that normal?
     
  7. Bill Gates macrumors 68020

    Bill Gates

    Joined:
    Jun 21, 2006
    Location:
    127.0.0.1
    #7
    "Very hot" is too subjective for us to say whether or not it's normal. It will definitely be noticeably hotter with the Nvidia GPU enabled though.
     
  8. oscar.lopez thread starter macrumors newbie

    Joined:
    Oct 16, 2010
    #8
    Thanks guys, gfxCardStatus solved the problem. Definitely a bug in Flash, it should be able to switch to the Nvidia card automatically.

    By the way, thanks to gfxCardStatus I also discovered that Skype turns on the Nvidia card, no matter what you're doing. Another bug.
     

Share This Page