Hyperdrive C HUB for macbook

Discussion in 'MacBook' started by kart, Apr 16, 2016.

  1. kart macrumors member

    Joined:
    Jul 16, 2011
    #1
    Firstly, I would like to start by saying I order and received my hyperdrive c usb hub for MacBook in a nice and timely matter, being in Australia the post from the states was quick and easy.
    This seemed to me to be the pick of the c hubs for MacBook for my application. Matching MacBook colours, through charging, 2x 3.0 USB ports, micro and sd card reading slots, the hub offers all necessary ports for me that don't come factory built into the MacBook.
    However, mine will not read my 2tb portable WD passport hard drive. Plugged in, all lights are on, (on the HD,) but then an unusual clunk sound from the HD, and the drive does not pop up in finder. Worried that my portable HD may have died on me, I plugged it into my iMac, to be pleasantly surprised that the clunk noise had gone and everything on my HD was still there.
    After a bit of googling on the clunk issue, it seems that this is how the HD acts when not given enough power to the drive. I then plugged in my Apple usb c to usb adapter with no dramas, the HD was 'clunkless' and showed up fine in finder. Again I tried plugging it into the usb c hub, again no luck. Final try, I shut and and rebooted the MacBook, plugged in the usb c hub and HD with no luck once again.
    Next I thought if it's a power issue, I'll plug the charger into the hub, along with the HD and see if that somehow gives the HD the necessary power to read and be recognised by the MacBook...success, it had worked.
    Now, this quite annoying..
    The whole idea of purchasing the usb c hub was to be completely portable, and have all the functions that the hub offers on the go. I use my portable 2tb HD very often, and it seems that the only time that I will be able to have the HD plugged in, is when the MacBook is also charging through the hub.

    Has anyone else got the hyperdrive c hub for MacBook and found this issue?
    I am quite disappointed, and have sent hyperdrive an email, to see if this is normal behaviour for the hub or if it is (hopefully) a faulty hub.
    There is no mention that I could see on their website stating that larger portable USB HD will not work due to a lack of power, and with portable hd's only getting larger in capacity then it seems that this hub would be useless in such application in a couple of years.
    Just for the record, my thumb HD worked fine. I also tried the 2tb HD in both USB ports.

    Does anyone have any thoughts on this?

    Much appreciated.
     
  2. Idarzoid macrumors 6502

    Joined:
    Mar 15, 2013
    #2
    It's a problem with most USB-C hubs, they don't provide enough power for external drive without having a power source plugged in.

    It's why I'm still looking for a good hub with at least 2x USB, HDMI or DP, power delivery and the ability to power an external drive. Anker Premium USB-C seems to do this fine, but I'm waiting for CalDigit's USB-C mini dock, see how it performs, seems like the best option.
     
  3. kart thread starter macrumors member

    Joined:
    Jul 16, 2011
    #3
    Ok..
    Anyone know how we find how much power HD's need from the USB c hub? Wondering if different brands draw different power..I was hoping it may have been a faulty c hub because like I said I often use my 2tb HD. Any possible ways around this? Besides buying a new hub?
    Cheers
     
  4. Idarzoid macrumors 6502

    Joined:
    Mar 15, 2013
    #4
    You can find the max power these USB ports provide on these hubs in their spec list. (Some hubs don't have this info or are harder to find.)

    Anker's Premium USB-C hub used to have an issue with providing enough power to external drives but seems like they've fixed it in newer hubs, dunno about other brands.

    You could try buying a new hub and see if it works, if not, return it, other option is to plug in USB-C power but that kinda defeats the point of rMB's portability.
     
  5. jayla008 macrumors newbie

    Joined:
    Jul 19, 2016
    #5
    How fast was delivery? I'm in Sydney and am considering purchasing this as well. However, I'm concerned about your issues you raised about devices requiring power and design set back that it only connects via a short USB C connection which can be damaged if handled incorrectly.
     
  6. c0ppo macrumors 6502a

    c0ppo

    Joined:
    Feb 11, 2013
    #6
    I have this problem with Anker USB-c hub, and with apple one as well. Even when it's connected to power outlet!
    Only thing that helps is restarting rMB, and then it works like a charm. Until it doesn't, and then I have to repeat the process all over again...
     

Share This Page