Hyperlink Issue, Inspector changes the text

Discussion in 'Web Design and Development' started by drewjarvis, Aug 26, 2008.

  1. drewjarvis macrumors newbie

    Joined:
    Aug 26, 2008
    #1
    I am trying to link to a website with the following content in its address:

    _CEL.asp?documentid=50%3E4%3A%2A1%2F%3E5%3E%2D6%2B%3D0A%2B4

    The inspector accepts this but then when I go back to it the inspector has changed it to:

    _CEL.asp?documentid=50>4:*1/>5>-6+=0A+4

    Why oh why?

    Thanks for any help I am new to using a mac and liking it so far

    Drew
     
  2. SrWebDeveloper macrumors 68000

    SrWebDeveloper

    Joined:
    Dec 7, 2007
    Location:
    Alexandria, VA, USA
    #2
    I know what's going on and why, but not sure about an easy fix.

    The original link is url encoded, meaning certain characters are translated to hexadecimal equivalents (called percent encoding). This allows content to be passed to the browser in an argument (in your link, it's "documentid") and the arguments themselves are kept intact. The browser/server handles the decoding automatically after processing the request.

    The inspector is decoding automatically for security vulnerability reasons, i.e. malicious code could be added into a link by simply encoding characters.

    Assuming the decoded URL breaks the link when your users click on it I am personally unaware of any means in iWeb Inspector -> Hyperlink to disable/enabling URL encoding per link and there is no easy way to edit the source other than export the HTML files and modify the link by hand, then publish.

    ** If the link works fine as decoded, don't worry about it **

    If anyone else has any other suggestions if the link does indeed fail, please post them here!

    -jim
     
  3. drewjarvis thread starter macrumors newbie

    Joined:
    Aug 26, 2008
    #3
    Thanks for the info, I downloaded the page and edited it in notepad (on a PC) I noticed that 3 additional characters were added to the link but the encoded % symbols were in tact, I removed the additional characters, saved the page and opened it up again. The link worked.

    Now I will just try to figure out how to change this in iWeb prior to publishing and I think it might work, will let you know after I have a go at home tonight.

    Thanks

    Drew
     

Share This Page