I accidentally set a disk's permissions to No Access

Discussion in 'Mac Basics and Help' started by b17777, Jun 16, 2009.

  1. b17777 macrumors member

    Joined:
    Jul 14, 2008
    Location:
    St.Paul MN
    #1
    I accidentally set a external disk's permissions to No Access. I can see it in disk utility and it says its mounted and working but is no longer on my desk top. I've searched but haven't found anything that works for me.I can't see the disk to change the permissions back. How do I fix this?
     
  2. msevild macrumors regular

    Joined:
    Oct 11, 2007
    Location:
    Schaumburg
    #2
    Even if the drive had been set to No Access you should still be able to see it on your desktop, just wouldn't be able to open it up. Were you changing the permissions using the Finder or terminal?
     
  3. b17777 thread starter macrumors member

    Joined:
    Jul 14, 2008
    Location:
    St.Paul MN
    #3
    In the finder.I set up a guest account for my niece and thought it would stop her from messing up my hard drive ( Funny ) I probably changed something else then also in the get info window. I've got my 300G iTunes folder and 100G
    of live recordings I've made on it.
     
  4. msevild macrumors regular

    Joined:
    Oct 11, 2007
    Location:
    Schaumburg
    #4
    Well I'll start at basics and move my way up. If any of these steps work, stop before continuing to the next steps.

    1) Go to the Finder preferences and make sure the checkbox is checked for external hard disks.

    2) Open up the Terminal Application from the Application -> Utilities folder

    3) type in the following command word for word and follow each line by hitting the return key

    cd /Volumes

    sudo chflags nohidden "name of your hard drive here, spaces and all, if any, case sensitive, and include the quotes"
    ^^^^you will be asked for your computer password after hitting enter above. The password field stays blank in terminal so don't be alarmed that you can't see yourself typing in the password field.

    killall Finder

    4) I'm actually going to stop there for now. Let me know if this works.
     
  5. msevild macrumors regular

    Joined:
    Oct 11, 2007
    Location:
    Schaumburg
    #5
    Well I guess the easier thing to start off with would have been to restart the machine. Unplug the drive and plug it back in.
     
  6. b17777 thread starter macrumors member

    Joined:
    Jul 14, 2008
    Location:
    St.Paul MN
    #6
    Did the restart already. After those commands I got
    Mac-mini:~ B$ cd /Volumes
    Mac-mini:/Volumes B$ sudo chflags nohidden "miniStack 465"
    Password:
    chflags: invalid flag: nohidden
    Mac-mini:/Volumes B$ killall Finder
    Mac-mini:/Volumes B$

    and that didn't do anything



    Thanks for the help
     
  7. b17777 thread starter macrumors member

    Joined:
    Jul 14, 2008
    Location:
    St.Paul MN
    #7
    Got it figured out
    sudo chmod 1775 /Volumes/
    fixed it
    Thanks
     
  8. surflordca macrumors 6502a

    surflordca

    Joined:
    Nov 16, 2007
    Location:
    Ontario, Canada
    #8
    For us who are learning this. What did this command do :confused:
     
  9. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #9
    The chmod command changes the permission of files/folders. The 1775 part sets the permissions so that the user and his group have read, write, and execute permissions (7), and everyone else only has read and execute permissions (5). The 1 is a sticky bit, but not sure it played a part here.

    So those permissions were applied to the Volumes folder where all drives are mounted at e.g., CD/DVD drive, internal HD, external HDs, etc.
     
  10. surflordca macrumors 6502a

    surflordca

    Joined:
    Nov 16, 2007
    Location:
    Ontario, Canada
    #10
    Tks for the info...
     

Share This Page