I appear to have broken my MBP installing Lion

magiic

macrumors regular
Original poster
Jun 17, 2008
238
11
San Jose
I bought Lion from the AppStore and installed it. Around the 90% mark the little box that says in a bunch of languages please hold down the power button to restart came up. I reset it and now when it boots it just sits at the apple logo with a little thing spinning underneath. I've tried booting holding alt/option and neither drive it shows does anything other than sit at the apple screen. How can I fix this?
 

yetieater

macrumors regular
May 6, 2007
136
0
USA
I bought Lion from the AppStore and installed it. Around the 90% mark the little box that says in a bunch of languages please hold down the power button to restart came up. I reset it and now when it boots it just sits at the apple logo with a little thing spinning underneath. I've tried booting holding alt/option and neither drive it shows does anything other than sit at the apple screen. How can I fix this?
This sounds an awful lot like what happened on my install. I expected to be able to boot nicely into Lion, but found that I couldn't get past the Apple logo.

First - if you leave your machine on for a couple of minutes, does the Apple logo eventually switch to a "No Entry" logo?

Second - have you tried resetting the PRAM?

Third - have you tried booting in Single User Mode, or at least tried booting with the Verbose command?
 

basher

macrumors 6502
May 27, 2011
447
18
Glendale, AZ USA
What you experienced is a Kernel Panic. Previous poster has good suggestions. If that still doesn't get it, you might try a clean install of Snowy then install Lion.

My fingers are crossed you have a backup of your data.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.