I bet you cant fix this lol

Discussion in 'Mac Basics and Help' started by anbuhydro, Feb 13, 2012.

  1. anbuhydro, Feb 13, 2012
    Last edited by a moderator: Feb 14, 2012

    anbuhydro macrumors newbie

    Joined:
    Feb 13, 2012
    #1
    Hello anyone and everyone! I joined today because i have a problem with my mac that nobody can help me fix... lets get to it!
    I have a 2007 2008 macbook model with osx 10.6 .8
    Two nights ago i went to upload my canon pictures to iphoto when my mac started to slow down tremendously. After running yasu and freemem my problem still persisted. i restarted and thats when my mac started biting the dust. after 10 min to login it took 15 min just to open the folder i clicked then another 20 just to load everything in that folder.....i went to disk utilities to fix some things and to repair the permissions it said 16 days and 11 hours!!!!! i ran fsck and still no help. I booted into safe mode where things ran a little smoother but still was slow.

    Now after i ran the same thing in safe mode ( repair disk permissions ) it only took a whole 3 minutes compared to the baffling 16 days crap. still no fix but i was told to boot with my apple disk because my disk needs to be repaired .... NOW heres the problem 1) i got the macbook from craigslist :( and the previous owner broke the cd tray im guessing...2) i do not have my snow leopard osx disk ..... so im guessing a normally easy fix has turned bad lol. i kinda dont know what to do from this point.. and im not buying an external drive... on top of all that my external HD only shows up in disk utility but not anywhere else...so i cant back up my files :(



    so lol if anyone could help me with this problem to get my mac to work i would very much appreciate it. i use my mac for photoshop and its my main source of income for now..:mad:

    this is my first mac so im kinda out on a limb here lol.
     
  2. Damo01, Feb 13, 2012
    Last edited: Feb 13, 2012

    Damo01 macrumors regular

    Joined:
    Feb 11, 2010
    Location:
    Australia
    #2
    the macbook that you purchased from craigslist did not came with installation disc?

    If it didn't, well you're seem damn out of luck there. But there is a solution to a problem. You can call apple and ask for a Mac OS X installation replacement disc.


    open up Activity Monitor to see if you getting lots of pages outs and post a screenshot of it here. To make screenshot you hold down apple command+shift+4.

    Once you got yourself a replacement disc. You can try doing a fresh reinstallation by booting off the Mac OS X installation from a USB or a firewire port. You can use Carbon Copy Cloner to clone the Mac OS X installation media onto a external drive.
     
  3. Tumbleweed666 macrumors 68000

    Joined:
    Mar 20, 2009
    Location:
    Near London, UK.
    #3
    yet no backups? Jeez :eek:
     
  4. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #4
    Why oh why do folks run without backups? OK, no point in ranting over what's done.

    OP: You are going to have to get the proper installation disks from Apple. Without them, it's pointless attempting much here. BUT, buy yourself an inexpensive USB hdd in order to try and get as much data off the machine prior to a reinstall of OSX.


    http://www.google.co.uk/products/ca...b8QOLnKz4Cg&sqi=2&ved=0CJEBEPMCMAA#ps-sellers

    See how cheaply you could have backed up your critical data for? Can you start the machine in recovery mode?

    Hold down the option key whilst booting.
     
  5. anbuhydro thread starter macrumors newbie

    Joined:
    Feb 13, 2012
    #5
    yea i kno i kno poo on me for not backing up lol now im kicking myself in the rump. i have to look in my storage for my install disk and buy an external cd drive


    but i probally can still back up my stuff if i can get my mac to read my external hdd. it shows up on disk utility but not anywhere else so i cant move files or use time machine... any help with that would be great and i can just reinstall osx on my macbook without worries.


    crazy thing is i havent tried recovery mode i only tried safe mode. ill try it now tho.... thanks for the replies
     
  6. anbuhydro thread starter macrumors newbie

    Joined:
    Feb 13, 2012
    #6
    well i fixed my computer.
    i just found my osx disk and installed a disk image to my external hdd and booted it from there...

    weird tho even tho i repaired the disk the problems still happened. So i just wiped it and re installed and used my time machine backup.

    thanks for all the help:D
     
  7. anbuhydro thread starter macrumors newbie

    Joined:
    Feb 13, 2012
    #7
    heeeyyyy i need help again lol

    so i reinstalled my os like i said and i started to use it again as normal. it started to freeze again a couple hours after then completely froze up. same problem as before. i did everything and backed it up and reinstalled again....this happens 3 more times!! so now i took out the hd and ram checked the connections then tried starting normally with 1 ram at a time. all i can do is boot from a external hd and never from the main hd unless i reinstall the os....

    so now im here...wondering what to do to stop the problem. i keep looking up stuff about it but i cant find any reasonable solution. so until i figure how to stop my computer from freezing im just going to leave it at the install screen. it could be possible that my main hd is messed up but when i run disk repair on it AFTER i install the os it says its fine....it only says i need to repair before i install the os and it runs for a few hours.

    btw its a 2007 macbook.

    any help would be awesome!! thank you
     
  8. Dweez macrumors 65816

    Dweez

    Joined:
    Jun 13, 2011
    Location:
    Down by the river
    #8
    When the system freezes, are you seeing the spinning beach ball? If you reboot the system immediately after a freeze does it perform alright, or is it still mucked up?

    I'd start with running memtest overnight. If the run is clean, then consider that perhaps your internal disk is having issues.
     
  9. anbuhydro thread starter macrumors newbie

    Joined:
    Feb 13, 2012
    #9
    yea i get beachballed everytime and it just sits at the apple loading screen for an hour then same original problem. i dont know what memtest is good sir...lol yea im hoping i dont have internal issues.
     
  10. anbuhydro thread starter macrumors newbie

    Joined:
    Feb 13, 2012
    #10
    ok so now when i run repair disk from disk utility from boot it says invalid node structure.....the hunt begins!
     
  11. jabbawok macrumors regular

    jabbawok

    Joined:
    Sep 30, 2004
    Location:
    Worcestershire
  12. anbuhydro thread starter macrumors newbie

    Joined:
    Feb 13, 2012
    #12
    Well from what ive been digging up. It can be fixed by diskwarrior.problem is i dint want to pay 100 bux for it. Unless i can put the dmg on another partition on ny external hd and boot it like i do my os
     
  13. chockymonster macrumors member

    Joined:
    Jul 9, 2008
    #13
    I'd suggest your disk is toast.
    I had exactly the symptoms you were describing on my MBP.
    Machine slowing down, taking ages to copy files, beachballing, tried to copy data off just in case time machine hadn't grabbed everything but the copy was taking hours do to 2Gb!

    Personally I'd pull the drive out, put a new drive in and use a usb->sata caddy to try and copy data off.
     
  14. Ccrew macrumors 68020

    Joined:
    Feb 28, 2011
    #14
    It's just like having unsafe sex. Seemed like a great idea at the time :)
     

Share This Page