I broke my MBP.. ? cannot boot from HD

Discussion in 'MacBook Pro' started by whosmatt, Apr 26, 2009.

  1. whosmatt macrumors newbie

    Joined:
    Apr 26, 2009
    #1
    Here's what I did:

    Booted Ubuntu 9.04 LiveCD.
    Ran the Ubuntu installer, installed to USB drive.
    Rebooted once the install was complete.
    Got the flashing "?"
    Now i can only boot to optical media. I can boot the Ubuntu CD and i can boot the 10.5 install DVD.

    Reset PRAM
    Reset PMU
    First I booted the 10.5 install DVD and repaired my HDD, no errors found.
    Then I ran Startup Disk and selected 10.5.6 on my HDD. Still "?" on boot.
    Then I restored my disk from my Time Machine backup. No problems there, but still "?" on boot.
    Then I did an Archive and Install of 10.5. No improvement.
    Then I did an Erase and install of 10.5. Still nothing. .

    Ugh.

    What do i need to do to get this f*cking thing working again? Apple wants $50 for a phone call...
     
  2. whosmatt thread starter macrumors newbie

    Joined:
    Apr 26, 2009
    #2
    A bit of an update: having nothing to lose, I booted from the Ubuntu CD and deleted all partitons on the disk, then made a small ext3 partition and a small swap partition and installed Ubuntu. Now I can boot linux. That's a start.
     
  3. whosmatt thread starter macrumors newbie

    Joined:
    Apr 26, 2009
    #3
    Solved it. I had to repartition the disk and wipe out MBR; that was keeping OS X from booting. Lesson learned. time machine FTW
     

Share This Page