i can not make calls with iphone after upgrading to ios5

Discussion in 'iOS 5 and earlier' started by malylo, Nov 10, 2011.

  1. malylo macrumors newbie

    Nov 10, 2011
    I think the current ios 5 version is mature, so I chose to upgrade my iphone to ios5. However, now I can’t make any calls and lose all of my contacts. What may lead my iphone not to make calls?
  2. Pooshka macrumors 65816

    Jun 28, 2008
    x.0.1 is not quite mature, not that there is anything wrong with iOS 5.

    Your issue is an isolated one. What do you mean you can't make calls? What happens when you launch the Phone app? Is there a dial pad?
  3. lelisa13p, Nov 10, 2011
    Last edited: Nov 10, 2011

    lelisa13p macrumors 68000


    Mar 6, 2009
    Atlanta, GA USA
  4. axiomic macrumors newbie

    Nov 12, 2011
    not an isolated case..

    I have the same problem.

    I just updated an iPhone 4 to iOS5, 5.0.1 (from iOS4) and now the phone is not working.

    When I click on the phone app I get a blank screen (except for the time /network /batt% bar and a blue/grey bar underneath that, and a black bar at the bottom with no words or buttons.

    It then automatically goes back to the home screen after about 10 seconds.

    I can call people from my contact list, but the screen goes blank and I cannot cancel the call. I can never get the dial pad.

    I have tried the following;
    - restoring the phone / complete wipe and reload of firmware
    - turning the phone off and on again
    no luck.

    I will attempt to roll back to iOS4..
  5. gentlefury macrumors 68030

    Jul 21, 2011
    Los Angeles, CA
    I'm just going to have to ask, because this is the cause of most iPhone problems...is your phone or has it ever been jailbroken?
  6. axiomic macrumors newbie

    Nov 12, 2011
    The phone has never been jail broken.

    I should clarify that the problem is not exactly the same as the OP, I can access my contact list, but not the phone app.

    I've just tried wiping the whole phone and booting as a new phone setup without restoring a backup, and the phone works perfectly. So the problem is occurring with the restore process.. So the question remains, how do I get my content and call / SMS history back?

    Thanks for your input.
  7. gentlefury macrumors 68030

    Jul 21, 2011
    Los Angeles, CA
    weird....so you have a corrupt restore file? My comp usually has a few restores available...do you have a slightly older one you can go to? Also, did you backup with iCloud? That worked great for me....I got my iPhone 4s and restored from iCloud and my phone was completely intact, even message and call history.

Share This Page