I can receive but not send texts

Discussion in 'iPhone' started by justflie, Dec 25, 2008.

  1. justflie macrumors 6502a

    justflie

    Joined:
    Nov 29, 2005
    Location:
    Red Sox Nation
    #1
    Hey folks,

    I'll be calling ATT again tomorrow, but I figured I'd give the community a shot at this problem.

    As the title belies, I can received text messages but not send them. It started happening relatively recently but I can't remember when. I've tried restoring my phone from a backup as well as a fresh start. I've tried clearing network settings and reseating the sim card. I called ATT and they took off the text plan from my account and put it back on and that was supposed to fix the problem. It didn't. The problem is not isolated to a single cell tower as it happened in a few different places all over the state.

    Any thoughts or similar situations? As to what could have brought this on, I think I've narrowed it down to either:

    1. when I switched out phones (in warranty) at the apple store.
    2. I had an employee discount applied to my account.

    I'm pretty sure it's one of these two possibilities. I'm leaning much more heavily towards number 2 as I've reset the phone and all other network related functions work fine (ie calls, web, incoming texts).
     
  2. CocoaPuffs macrumors 68010

    Joined:
    Aug 23, 2008
    #3
    Sounds like you may not have your text message enable on your AT&T plan.
     
  3. Rayfire macrumors 68020

    Rayfire

    Joined:
    Aug 25, 2008
    Location:
    PNW
    #4
    Do that, and in addition go to your OLAM and see if you have a text plan (if they did place it back) and how is your meter for the Data Usage look?
     

Share This Page