I cannot delete an app, its stuck trying to update.

OrlandoTragic

macrumors 65816
Original poster
May 13, 2007
1,387
129
Orlando, FL
Instagram must have tried to auto-update last night.

On my home screen, it shows up with the progress bar, but when I hold my finger down, I cannot delete it.

I've tried resetting my phone and its still happening. Any thoughts?
 

allistera

macrumors regular
Sep 17, 2012
183
57
Same thing happened to me when I was restoring from iCloud backup - I simply restarted the phone and it started downloading.
 

OrlandoTragic

macrumors 65816
Original poster
May 13, 2007
1,387
129
Orlando, FL
Weird. I actually searched for Instagram in the App Store, and it lets me open the app from there, which means that its actually installed on my phone, but the icon is stuck.

Ugh.
 

Ram27

macrumors member
Feb 19, 2012
90
0
Go into the App Store and the updates section, there should be an update in progress or some such.
 

Tiger8

macrumors 68020
May 23, 2011
2,479
648
Instagram must have tried to auto-update last night.

On my home screen, it shows up with the progress bar, but when I hold my finger down, I cannot delete it.

I've tried resetting my phone and its still happening. Any thoughts?
This sometimes happens with earlier versions of iOS. What you need to do is go to the App store, find the app in the store, and 'install it' if you have that option. That worked for me once.

The other option is to turn off cellular data and Wifi and after a while the update times out
 

BvizioN

macrumors 601
Mar 16, 2012
4,975
2,778
Manchester, UK
I had the same problem today! You can't remove it untill is fully updated! What I did is, i powered OFF the phone and then back on! App updated and then I was able to remove it.
 

kerrikins

macrumors 65816
Sep 22, 2012
1,198
424
Try going to the App Store -> Updates -> Purchased. I found that the ones that were "stuck" had little paused signs beside them and when I clicked those or fixed the problem. Easier than searching for each one.
 

kenkamm

macrumors regular
Oct 25, 2008
110
0
I've tried each of the suggestions here except for a full restore and nothing has worked so far. :(
 

mikeyiphone

macrumors regular
Jun 10, 2009
157
10
I had a similar issue.

Instead of deleting them on the phone hook it up to iTunes and remove the apps from there. Make sure they are removed from the phone, then resync them from iTunes onto the phone.

It worked for me.

Let me know.
 

xyion1

macrumors regular
Oct 26, 2007
128
9
This happened to me and was murdering my battery life (like 1% every 3 minutes) so I just plugged it into my iTunes and had the latest apps installed via sync. Now my battery life is just fine and the app is updated. (It was iTransit if it matters...)
 

freejack

macrumors regular
Nov 15, 2007
176
38
Long Island, NY
This happened to me and was murdering my battery life (like 1% every 3 minutes) so I just plugged it into my iTunes and had the latest apps installed via sync. Now my battery life is just fine and the app is updated. (It was iTransit if it matters...)
The above suggestion works but if you don't have access to itunes, I found the following works also.

Just join a wifi access point and the app will begin downloading within a minute. For some reason apps will become stuck at waiting if you try to update using cellular data. Even enabling updates via cellular does not fix this. Anyway, it happened twice to me and both times, hooking up to wifi fixed it.
 

Vertigo50

macrumors 65816
Apr 11, 2007
1,197
131
I agree with others here.

Mine was monumentally stuck, to the point where it was showing a "generic" icon.

I tried everything and finally plugged it into iTunes, when into the app section and removed it from there. Not from the "iPhone screen" in iTunes, but removed it from the actual list. Then I downloaded it fresh, and it worked.
 

kenkamm

macrumors regular
Oct 25, 2008
110
0
Connecting to a wifi network worked for me, pretty much. It was still acting strange, but after a restart or two, it resolved.