Resolved I Cannot Restore My JB Devices From iTunes! Nor from iOS Device Itself, Stuck on Spin

Discussion in 'Jailbreaks and iOS Hacks' started by HappyDude20, Apr 20, 2014.

  1. HappyDude20, Apr 20, 2014
    Last edited: Apr 20, 2014

    HappyDude20 macrumors 68020

    HappyDude20

    Joined:
    Jul 13, 2008
    Location:
    Los Angeles, Ca
    #1
    I'm wanting to restore both my iPhone and iPad. I have a MacBook Pro here in front of me and i've connected each device and tried to restore but to no avail. When I try, I get an error saying my iPhone or iPad isn't the correct build and there was an error.

    I've then tried to "erase all content and settings" and my device goes to a black screen with that spinning loading icon in the middle. However this black screen with spinning circle in the middle remains. At first I thought it was just the iOS device doing it's thing but i've left it for more than 24 hours in this state, got frustrated, turn off and on the device and it turns back on to normal as if nothing at all happen. Nothing has been deleted from my devices at this point.

    And here I am now. I'm guessing this issue has to be cause my iOS devices are jailbroken, but that's all thats going on.

    I'm super confused. Any help is appreciated.

    To summarize:
    1. Both iOS devices tried to restore in iTunes on MBP. But am given an error message saying, "The device isn't eligible for the requested build."
    2. I tried "erase all content and settings" but the device stays stuck on the spinning/loading black screen, with no end in sight as long as 24hours so far..
    3. I have to assume it's cause my devices are jailbroken, but I can't imagine how? Perhaps a source?
     
  2. HappyDude20 thread starter macrumors 68020

    HappyDude20

    Joined:
    Jul 13, 2008
    Location:
    Los Angeles, Ca
    #2
    Solved!

    I opened Finder>Go> typed in /privacy

    went into the "etc" folder, found a documents titled "hosts"

    made a copy onto my desktop, opened with textedit, on the final line added a single "#" sign, saved the document, re-added it back into that etc folder replacing the "host" document..

    restarted iTunes and both iOS devices restored as normal.

    :D:D:D:D:D:D
     
  3. cnotes2019 Suspended

    Joined:
    Aug 17, 2013
  4. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #4
    what iOS firmware version are you trying to restore to? You can only restore to iOS 7.1, nothing else

    2. yes, it will stay stuck on an endless spinning circle if you're jailbroken and you tap "erase all content and settings". Fortunately, evasi0n makes it that a hard reboot will kick you out of this boot loop (pre iOS 5 jailbreaks would cause you in a boot loop and only a restore to the latest iOS version would get you a usable device again). Despite evasi0n's mechanism to prevent a boot loop, I would still advise against tapping that if you want to remain jailbroken
     

Share This Page