I can't add mobile number to iMessage and FaceTime

Discussion in 'iPhone' started by preyan, Feb 15, 2017.

  1. preyan macrumors 6502

    preyan

    Joined:
    Aug 31, 2007
    Location:
    South Africa
    #1
    Please help. I have an iPhone 7.
    I want to add my new mobile number to iMessage and FaceTime. How do I add it? Maybe I need to add my mobile number somewhere else first (but where) before these settings will pick it up.

    Under iCloud when I view my account, my new mobile number is there. It is correct and it says VERIFIED next to it. Is there somewhere else that I need to add it first!
     
  2. noobinator macrumors 601

    Joined:
    Jun 19, 2009
    Location:
    Los Angeles, CA
    #2
    If it's not showing up try turning your phone off and back on, then try a hard reset, and if this doesn't work try a restore. Maybe remove and replace sim card too?

    It should just show up automatically.
     
  3. Illumiiinati macrumors member

    Illumiiinati

    Joined:
    Sep 6, 2015
    #3
    Did you try checking settings - message - send and receive ( email and mobile number )
     
  4. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #4
    There was an iMessage outage I heard so wondering if that's the reason it's giving you problems.
    Other than that go to settings,messages, turn iMessage to on.
    Then scroll down to the send/receive option and select your phone number.
     
  5. nav92 macrumors member

    nav92

    Joined:
    Feb 25, 2013
    #5
    You can try resetting the networks settings of the phone. Could be an issue with the cellular company.
     

Share This Page