I can't burn DVDS !

Discussion in 'MacBook Pro' started by Rashid Alkaabi, Feb 20, 2010.

  1. Rashid Alkaabi macrumors member

    Jun 17, 2008

    I have been trying to burn DVD on my macbook pro (late 2008) using Disk Utility and Burn and I always faced a message that says: " The disc can't be burned; it might be incompatible with this sic drive. Please try a different brand of disc, or try burning at a slower speed". I can burn CDs just fine .. but when it comes to DVD +R +RW +DL I cannot ! I have important files that I need to burn but I can't due to this problem. I'd like to mention that I have tried 2 different DVD brands with the speed of x2 and x4 with no luck!

    Help is highly appreciated.

  2. bigaudiofanatic macrumors regular

    Dec 17, 2008
    What are you trying to burn? If it is movies I use mac the ripper and roxio popcorn.
  3. Rashid Alkaabi thread starter macrumors member

    Jun 17, 2008
  4. gfiz macrumors 6502


    Dec 18, 2009
    Have you burned dvd's in the past and now it's not working, or first time you've tried?
  5. mac88 macrumors 6502

    Aug 7, 2008
    Boston, MA.
    That would be my question. If you have and had success, I would say maybe there is something wrong with your superdrive.
  6. aross99 macrumors 68000


    Dec 17, 2006
    East Lansing, MI
    I believe there are separate lasers in the drive for DVD's vs. CD's. I had the reverse issue - couldn't burn CD's. but I could burn DVD's. Turned out to be a problem with the drive.

    If you can't EVER burn a DVD, even with different types of media, I would suspect a drive issue. If you have Apple Care, or are still under warranty, I would take it into the Apple Store for repairs.

    If you are out of warranty, you might think about just getting an external USB DVD writer for those times when you need to burn DVD's. They are pretty cheap - less than $75... OWC has both internal and external replacement drives, but I suspect the internal drives are pretty tricky to replace:

  7. jnev macrumors newbie

    Sep 6, 2007
    I have the exact same issue with my superdrive. the potentiometer just went out in it most likely, and there's no easy way of fixing it (to my knowledge). you can either replace the superdrive or buy an external optical drive (what I did, it's way cheaper).
  8. hundert macrumors regular


    Jan 24, 2010

Share This Page