I can't call anymore after JB 3.1 on 3GS

Discussion in 'Jailbreaks and iOS Hacks' started by seppevs, Oct 3, 2009.

  1. seppevs macrumors newbie

    Oct 3, 2009
    Hi, I have a iPhone 3GS which was jailbroken with 3.0 (purplerain).
    Today, I downloaded the official 3.1 firmware and patched it with PWNage. Then I did a restore with my patched firmware. Everything went smoothly: I have now a jailbroken 3.1 3GS device. Except one problem: I can't call anymore!

    I don't depend on software unlock, my device was already unlocked when I bought it (I live in Belgium). My provider is "Proximus (BE)". I get now "no service" and I can't call anymore. I left the activation setting to "no", since I don't depend on software unlock.

    Can anyone help me?!
  2. IBradMac macrumors 68000


    Jun 27, 2008
  3. strongesthylian macrumors newbie

    Oct 25, 2007
    I don't know if this will work, but try resetting your network settings?
    Settings > General > Reset > Reset Network Settings
  4. TMar macrumors 68000


    Jul 20, 2008
  5. seppevs thread starter macrumors newbie

    Oct 3, 2009
    I already tried that, it didn't work :(
  6. Buskape macrumors 6502


    Dec 10, 2008
    NGC 4889
    Maybe you should have put Yes for the unlock, it wouldn't have hurt in any way, because now "maybe" your device got locked to AT&T because of pwnage tool, i don't know..
  7. ebika macrumors 6502

    Nov 17, 2008
    I was going to suggest setting the activate to "yes", but I doubt it would help.
  8. dhlizard macrumors G4


    Mar 16, 2009
    The Jailbreak Community
    If Proximus is an official iPhone carrier, then the sim should unlock the phone so no was the correct choice.

    If Proximus is not an official carrier, then yes would be the correct answer.

    If I read your post correctly, Proximus is an official carrier so I don't know whats up ??
  9. Moi un Mouton macrumors 68000

    Mar 18, 2008
    Bracknell UK
    The way I read your post, you have a factory unlocked iPhone 3GS, bought from the official Belgium carrier, which you have been using on the non-official carrier Proximus. And you've been using it fine with your current Proximus SIM.

    Now you've built and installed a custom 3.1 file but you can't make or receive calls. The iPhone is not giving you a message that it doesn't like the SIM, you just have no service.

    If that is right, I'd suggest you rebuild your custom file and choose Activate.

    If that doesn't work then I guess you'll have to go to stock 3.1 and wait for the release of the jailbreak for that :(
  10. seppevs thread starter macrumors newbie

    Oct 3, 2009
    I fixed it! I reinstalled the custom 3.1 firmware, and after the first reboot I've noticed a screen now which prompts me to activate my iPhone yes/no (or something like that). I clicked "yes" and now everything works again (and I still have my JB). I think I clicked away this screen the first time too quickly.

    Thx for your help!

Share This Page