Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

I can't copy and paste on my mac

sandrasccr

macrumors newbie
Original poster
Jan 11, 2012
4
0
Its been a problem for about a week now and since i have finals/school project due next week i need this fixed asap.

Its a new mac ( i got it in september). Im mad that this has happened. can anyone help me?
 

TjeuV

macrumors 6502
Dec 14, 2011
306
4
Belgium
Its been a problem for about a week now and since i have finals/school project due next week i need this fixed asap.

Its a new mac ( i got it in september). Im mad that this has happened. can anyone help me?

how could you not copy/paste?

just select what you want to copy > cmd + c > cmd + v ?
 
Comment

sandrasccr

macrumors newbie
Original poster
Jan 11, 2012
4
0
how could you not copy/paste?

just select what you want to copy > cmd + c > cmd + v ?

that doesn't work.. it only works if i want to paste into finder but it doesn't work in word or on webpages.
 
Comment

saberahul

macrumors 68040
Nov 6, 2008
3,631
101
USA
What are you trying to copy and paste? If cmd + c or cmd + v isn't working, have you tried right clicking and then selecting copy, and then paste?
 
Comment

sandrasccr

macrumors newbie
Original poster
Jan 11, 2012
4
0
What are you trying to copy and paste? If cmd + c or cmd + v isn't working, have you tried right clicking and then selecting copy, and then paste?

Usually just like a paragraph of words or a weblink, I've also tried graphs and tables.

Thats not working either neither is clicking edit then cut/copy/paste
 
Comment

mdamour

macrumors newbie
Apr 25, 2011
4
0
I Can't Copy or Paste either

Yikes... I'm having this same thing happen. I mainly use copy and paste in Final Cut Pro X and over the last few days it has been happening... that is a HUGE inconvenience not to be able to use copy + paste in that program... but today I tried using it in the Finder (to copy an icon from one folder to another) and it doesn't work. It says the copy function is available (and looks to be copying to the clipboard) but once I "copy" it there is no paste option available.

It does seem to be working in Safari and Word.

@sandrasccr

What programs did you use to get this to start working again? What programs were you using that it wouldn't work in? Thanks for your help.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.