I can't deactivate sudden motion sensor

Discussion in 'MacBook Pro' started by kris248, Mar 9, 2012.

  1. kris248 macrumors newbie

    Joined:
    Mar 9, 2012
    #1
    Hello everyone,
    After old hdd in my mid2009 MacBook Pro broke down I replaced it with WD Scorpio Blue. Unfortunately I bought a version with shock guard. In effect well known conflict with built in sudden motion sensor freezes my Mac for 1-2 seconds in every 5 minutes. I tried to deactivate sudden motion sensor but I can't. When I try to check whether it is active by typing "sudo pmset -g" in terminal, this is what I get back:
    [​IMG]

    Any ideas how to fix it?
     
  2. iforbes macrumors 6502

    Joined:
    Dec 21, 2011
    #2
    I think you need to start with "sudo pmset -a sms 0" return/password/etc then "sudo pmset -g"
     
  3. kris248 thread starter macrumors newbie

    Joined:
    Mar 9, 2012
    #3
    I tried but after typing "sudo pmset -g" - the same message again..
     
  4. iforbes macrumors 6502

    Joined:
    Dec 21, 2011
    #4
    so there is nothing after "Currently in use:"?

    Which OS are you running?
     
  5. kris248 thread starter macrumors newbie

    Joined:
    Mar 9, 2012
    #5
    Exactly - nothing after. I use 10.6.8 Snow Leopard.
     
  6. iforbes macrumors 6502

    Joined:
    Dec 21, 2011
    #6
    Have you tried Disk Utility to verify the disk and repair permissions?
     
  7. kris248 thread starter macrumors newbie

    Joined:
    Mar 9, 2012
  8. iforbes macrumors 6502

    Joined:
    Dec 21, 2011
    #8
    Just checking some old posts...

    What is your default language setting? System Preferences->Language & Text->Language. Have you switched it lately? Eliminated any languages?

    Tried an SMC reset?
     
  9. kris248 thread starter macrumors newbie

    Joined:
    Mar 9, 2012
    #9
    I tried almost everything. SMC reset too. My default language is Polish, I haven't changed it since I installed Snow Leo on my new hdd. I also tried to switch my language settings - still nothing...
     
  10. iforbes macrumors 6502

    Joined:
    Dec 21, 2011
    #10
    Change it to english and see if there is a difference.
     
  11. kris248 thread starter macrumors newbie

    Joined:
    Mar 9, 2012

Share This Page