I can't get my iPhone out of recovery mode!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by orkyz!, Sep 5, 2011.

  1. orkyz! macrumors member

    Jul 18, 2010
    I have had my jailbroken iPhone 4 for about a year now, and it had been running smoothly until it just got stuck on recovery mode yesterday. I tried the hold power button and home button thingy but it didn't work. I tried tiny umbrella and it didn't work. iTunes doesn't even recognise my phone's name! It doesn't give me an option for me to restore from a backup! I tried restoring but even that failed. It says The iPhone "iPhone" could not be restored. An unknown error occurred (1013).
    Please help!
  2. Fulaeetoy macrumors newbie


    Aug 11, 2010
    Your current firmware? Last thing you do when your phone goes to recovery mode?
  3. Frosticus macrumors 6502a


    Oct 4, 2010
    Bristol, UK
    This is why I don't jailbreak. :rolleyes:

    Other than checking you've got the latest version of iTunes and trying a restore, I think you might be out of options.
  4. ManBearWaffle macrumors member

    Jan 24, 2010
    If you're on a Mac, do the following:

    Open Terminal
    Type "sudo nano /etc/hosts" without quotes, of course
    Type in your password
    Put a # in front of the IP addresses for gs.apple.com
    Press CTRL + O to save and then CTRL + X to exit

    Now, restore your iPhone.
  5. orkyz! thread starter macrumors member

    Jul 18, 2010
    I'm not on a mac :(
    I updated iTunes and tried to restore my iPhone again but it didn't work.
  6. Frosticus macrumors 6502a


    Oct 4, 2010
    Bristol, UK
  7. mindyish macrumors member

    Sep 3, 2011
    Not sure what you were doing when it went into recovery mode as you didn't include that in your post but I recently had this issue and was able to fix it with tinyumbrella recovery loop fix :


    Download it from there.

    It may give you an error when you try and run it depending on if you are on mac or pc and such. The error will say you are missing a zlib.dll file. You can download that from here:


    I didn't trust saving directly into my system folder but you have to put it directly in the same folder as the program that needs it (after unzip) and it should run then because the program will try and locate this dll on its own.

    This worked for me getting out of recovery and itunes wouldnt let me restore.
  8. piethingy macrumors newbie

    Mar 2, 2013
    Thank You

    ManBearWaffle your solution was the only thing that worked for me Thank You


    Thank you so much
  9. rociogzzs macrumors newbie

    Mar 15, 2013

    What password did you insert? the one of your Mac or your iphone's password???? :(



    I did everything but when y try to CTRL + X (to exit) the window doesn't close. =( I don't know what to do!! :(:(:(:(:(:(:(:(:(
  10. TheRainKing macrumors 6502a


    Jun 11, 2012
    If you are stuck in Recovery loop you should try the recovery loop fix in redsn0w. And if that don't work try the one in iREB.
  11. sha4000 macrumors regular

    Feb 19, 2012
    This worked for me. My sons 4 battery died so I ordered one from Amazon but when I installed it the thing was on recovery mode. I guess from me holding power and home so many times to see if it would boot up before I figured out the battery was gone. Anyway I downloaded Tinyumbrella and kicked it right out of recovery mode. Thanks for the post.
  12. Jonathaange macrumors newbie

    Aug 11, 2015
    Altogether there are four steps to kick iPhone out of recovery mode.
    Get the data cable out of your computer then turn off your iPhone.

    Long press "Home" button until you have your iPhone connected to the computer with the data cable. Then release the "Home"button.

    Now you iPhone has entered recovery mode smoothly.

    Then choose both the "Home" and "Power" button at the same time until you see a "white apple" logo on the screen. Then you can exit the recovery mode.
    Hope it helps. I fix iPhone stuck in recovery mode with this method and it worked for me.
  13. bbrks macrumors 65816


    Dec 17, 2013
    I think you are about 2 years late with that answer :)

Share This Page