I can't install the latest Safari/Security software

Discussion in 'Mac Basics and Help' started by melvina, Oct 23, 2009.

  1. melvina macrumors newbie

    Joined:
    Oct 23, 2009
    #1
    Hello,

    So, I went out and got the new Nano 16g and had to install the latest version of itunes to get it to work. No problem, everything was working fine for a couple of days. I tried to browse the itunes store today, but it wouldn't work and a message stating that I need the latest version of Safari to access the itunes store.

    I tried to download Safari but it wouldn't work, because apparently, I need the latest security update before I can get Safari to download. I have tried to get the Security to download a few times now and a message stating "Security won't download to your computer". This has become frustrating and I am limited with my mac skills and computer skills in general. Any help would be appreciated.

    I have the older 10.4.11 core 2 duo osx. I think I am choosing the appropriate software options. (Tiger) I have enough memory left on my computer as well.

    Thanks,

    Mel
     
  2. melvina thread starter macrumors newbie

    Joined:
    Oct 23, 2009
  3. albionstudio macrumors newbie

    Joined:
    Oct 24, 2009
    #3
    i have the similar problem that the latest safari with the updated displays of coverflow will not connect to connect to my tyger that has been updated to snow leopard
     

Share This Page