I connect my macbook pro 13 to Full HD monitor, but It's not sharp!!?

Discussion in 'Mac Pro' started by YoYo93, Dec 12, 2011.

  1. YoYo93 macrumors newbie

    Joined:
    Nov 1, 2011
    #1
    Hi everyone

    Today I bought LG FLATRON E2290 one it's new monitor with HDMI, Anyway I back to my home to then use "Mini-display to HDMI cable" and connected to the monitor, in the first the desktop of my mac show up with 1080p resolution on the monitor and it was very nice.... BUT!... The dock, Bar, and the items on the desktop didn't display on the monitor, Then I enable the mirroring and everything show up but the 1080p resolution didn't work! the monitor transform to 720p or less and not sharp like on the first!!! :(((

    :confused::confused::confused::confused::confused:

    SORRY FOR MY BAD ENGLISH BUT I HOPE THE POINT IS CLEAR
     
  2. ActionableMango macrumors 604

    ActionableMango

    Joined:
    Sep 21, 2010
    #2
    This is the Mac Pro forum (desktops). You will probably get better help in the MacBook forum (laptops).

    Mirroring will result in the problem you experienced when the two displays have a different resolution. Do not use mirroring in your situation.
     
  3. YoYo93 thread starter macrumors newbie

    Joined:
    Nov 1, 2011
    #3
    Sorry about that!

    And about the mirroring... If I don't use it the resolution is truly amazing but the dock, bar, the items on the desktop doesn't display on the monitor!!

    This my problem I want to view all things :(
     
  4. elvisizer macrumors 6502

    Joined:
    May 29, 2003
    Location:
    San Jose
    #4
    the mac is treating the display as an HDTV rather than a computer monitor and is enabling overscan compensation. Connect to a DVI port on the display instead of HDMI.
     
  5. ActionableMango macrumors 604

    ActionableMango

    Joined:
    Sep 21, 2010
    #5
    Don't do mirroring.

    Elvisizer is right, you have to eliminate overscan. Switching to DVI might do the trick, but it might not. You can use switchresx to eliminate overscan in OS X.

    However, your TV might also have overscan. Make sure it is in a perfect pixel mode, PC mode, or whatever LG calls it. Every brand calls it something different, so you'll have to figure that out for yourself.
     
  6. YoYo93 thread starter macrumors newbie

    Joined:
    Nov 1, 2011
    #6
    LOL guys it work after I close the macbook all thing show up on full hd

    THANK YOU
     
  7. peabo macrumors regular

    Joined:
    Feb 14, 2008
    #7
    If you want to still use both displays but have the menubar and dock on the external screen, try this:

    Leave your macbook open
    open system preferences
    go to 'displays'
    click 'arrangement'
    Make sure 'mirror displays' is not checked
    finally, where you see the two, blue boxes inside the preference pane, drag the white menubar from the smaller box to the big one.

    I hope this helps!
     
  8. YoYo93 thread starter macrumors newbie

    Joined:
    Nov 1, 2011
    #8
    Guys! it's work


    and all what I did is....... Close my macbook pro then the display show on the monitor :cool:

    and when I open my macbook pro the monitor hide the dock again
     

Share This Page