I could use some advice.

Discussion in 'iPhone Tips, Help and Troubleshooting' started by jasonf, Jul 5, 2007.

  1. jasonf macrumors newbie

    Joined:
    Jul 5, 2007
    #1
    bought an iPhone 2 days ago, had to exchange it because of multiple dead pixels. Got it home and I hooked it up to iTunes and started the activation. filled in my info and it popped up with a message that said "Activation could not be completed on current sim card, use sim card that came with iPhone or get a replacement from at&t" well i was using the sim card that came with it, so i went to at&t and asked them for a replacement, they didn't even know where the sim card was located. so I brought my new sim card home and got the same activation error. So yesterday i took it up to the apple store, told them my problem, they didn't even look at it, they just then a new iphone at me and sent me on my way, i got it home and it has the same problem. So now after my soul has died. I am out of ideas, I'm kinda tired of going to the apple store. I read someone had a similar problem and their solution was make an emergency call and it asked them to deactivate the airplane mode. i tried that and it didnt prompt me. any other ideas...Please...
     
  2. Furgster macrumors 6502

    Furgster

    Joined:
    Jun 16, 2007
    #2
    it seems strange that with different iphones you get the same error, it almost suggests that there is something wrong with iTunes or computer rather than the iphone
     
  3. jasonf thread starter macrumors newbie

    Joined:
    Jul 5, 2007
    #3
    yeah

    I actually thought that same thing, i have a macbook pro and I tried updating itunes again, still same thing, so then I updated itunes on my roommates PC and tried it , got the same problem. with 2 different sim cards
     
  4. Furgster macrumors 6502

    Furgster

    Joined:
    Jun 16, 2007
    #4
    im not sure that you can do this with an iphone that has not been activated, but if you hold the hold button long enough i think it will reset, maybe that will help. but this is a strange problem i have not seen before, most people are able to get theirs fixed after getting a replacement
     

Share This Page