I did something very bad. I deleted libstdc++.6.0.9 from usr/lib folder and now my mac won't boot

Discussion in 'OS X Mavericks (10.9)' started by youngpriz, Jun 13, 2015.

  1. youngpriz macrumors newbie

    Joined:
    Jun 13, 2015
    #1
    Someone please help. I really messed up my IMac. I was trying to follow some instructions on installing something, that required me to replace some .dylib files. all of them were replaced fine but one. I found the original file in the folder (libstdc++.6.0.9) and moved it to the trash. The i moved the replacement one into the folder. I immediately lost all items on the desktop and the finder and all apps closed. I tried to restart, and now it wont even get to the login screen. I'm completely stomped and could really use some help. Any ideas or solutions would be greatly appreciated.
     
  2. ricede, Jun 13, 2015
    Last edited: Jun 14, 2015

    ricede macrumors regular

    ricede

    Joined:
    Aug 16, 2010
    Location:
    Inside
    #2
    Start the iMac & immediately hold down the command + option + R keys.
    this will take you to Internet recovery ( make sure the iMac is connected to the Internet ! ). You can re-install the OS from there. This can take a long time to download - depending on your Internet speed )

    This will not wipe your personal files - only replace the OS.

    Be aware that it will replace the OS with the OS that originally came with the imac. If it came with Mavericks then it will re-install Mavericks. If it came with Mountain Lion then it will re-install Mountain Lion .

    Alternatively :

    Do you have any sort of backup ?
    If you do - open the backup on another mac & find the file you deleted by mistake.

    Then launch the iMac in TargetDiskMode through another mac.
    http://osxdaily.com/2010/04/07/how-to-boot-a-mac-in-target-disk-mode/

    In TargetDiskMode your iMac HD will appear on the other macs desktop. Move the deleted file ( which you got from the backup ) back into place in the iMac HD folder on the desktop - then eject the iMac HD from the desktop of the other mac.

    Restart your iMac.
     
  3. rosgeorge macrumors newbie

    Joined:
    Jul 14, 2015
    #3
    youngpriz, Im having the exact same issue with libstdc++.0.6.9.dylib file. Have you solved this in any way?
    your help would be highly appreciated.
     
  4. youngpriz thread starter macrumors newbie

    Joined:
    Jun 13, 2015
    #4
    I ended up taking it to geek squad where I believe they backed up what was on the hard drive and did a clean install of the osx
     

Share This Page