I Dont Autocorrect to I. D.o.n.t

Discussion in 'iOS 12' started by BS126600, Mar 25, 2019.

  1. BS126600 macrumors newbie

    Joined:
    Sep 13, 2018
    Location:
    New Jersey
    #1
    I am noticing that after the IOS update to IOS 12.2 that when I try to type I Dont it autocorrects to I. D.o.n.t
    I have seen multiple texts from others as well but nothing on the forums. Is this a glitch?
     

    Attached Files:

  2. mikzn macrumors 65816

    mikzn

    Joined:
    Sep 2, 2013
    Location:
    Vancouver
    #2
    I don’t think so

    Just tried and auto correct was fine on iPad
     
  3. jsmith189 macrumors 65816

    jsmith189

    Joined:
    Jan 12, 2014
  4. BS126600 thread starter macrumors newbie

    Joined:
    Sep 13, 2018
    Location:
    New Jersey
    #4
    It does it over and over for me lol. Oh well.
     
  5. gwang73 macrumors 6502a

    gwang73

    Joined:
    Jun 14, 2009
    Location:
    San Francisco Area
    #5
    Try resetting your keyboard dictionary in Settings-->Reset-->Keyboard Dictionary
     
  6. BS126600 thread starter macrumors newbie

    Joined:
    Sep 13, 2018
    Location:
    New Jersey
    #6
    Didn’t work. I am starting to see friends of mines phones doing it as well.

    I. D.o.n.t
     
  7. gwang73 macrumors 6502a

    gwang73

    Joined:
    Jun 14, 2009
    Location:
    San Francisco Area
    #7
    Weird. I don't have that issue on my phone. Not sure what's causing it if a reset didn't work.
     
  8. Apple blogger macrumors 6502a

    Joined:
    Feb 28, 2013
    #8
    I don’t have this issue

    Edit: it seems there’s something wrong with your autocorrect. Remove this keyboard and select another random one. Then switch back.
     
  9. Altis macrumors 68030

    Joined:
    Sep 10, 2013
    #9
    It's so miserable that you have to reset the entire thing to get rid of a single learned word. As if they can't come up with something better than that.
     
  10. Shirasaki macrumors 604

    Shirasaki

    Joined:
    May 16, 2015
    #10
    You know, this is Apple, dictatorship style company — “Customers are fools. We know everything”.
    --- Post Merged, Mar 27, 2019 ---
    i Don’t i don’t i don’t i don’t i don’t

    Seems ok for me.
     
  11. jhfenton, Mar 27, 2019
    Last edited: Mar 27, 2019

    jhfenton macrumors 6502a

    jhfenton

    Joined:
    Dec 11, 2012
    Location:
    Cincinnati, Ohio
    #11
    I don't see any issues with "I don't."

    But if we're grumbling about iOS auto-correct, try typing "el niño" or "la niña" without iOS capitalizing them. Whether in English or Spanish, iOS believes it more likely that I am talking about climate patterns than actual children. I can't find any way to make it stop.
     
  12. tinylittlerobots macrumors newbie

    tinylittlerobots

    Joined:
    Apr 22, 2019
    #12
    I have been that issues for a couple weeks now ever since I got my iphone XS and it was annoying me tremendously. I fixed it by just creating a Keyboard Replacement of "don't" for when I type "dont" as the "shortcut". Work's fine now!
     
  13. ManuCH macrumors 6502a

    Joined:
    May 7, 2009
    Location:
    Switzerland
    #13
    If resetting the dictionary didn't work, I see 2 possibilities: you either have a contact stored which contains this string, or one or more text messages containing the autocorrected string.

    I would delete any relevant messages, contacts, apps, whatever where autocorrect might get its clues from, then delete the dictionary again.
     
  14. nwmtnbiker macrumors 68000

    nwmtnbiker

    Joined:
    Apr 5, 2011
    Location:
    Fidalgo Island
  15. gaanee macrumors 65816

    Joined:
    Dec 8, 2011
    #15
    What happens if you delete the auto-corrected word and re-type the way you want it? Possibly a way to retrain iOS autocorrect. Somehow iOS registered the wrong word in your typing - messages, email, notes...Maybe, if you delete the wrong word and type the correct one, iOS will retrain its autocorrect dictionary.
    It's baffling how iOS doesn't provide access to auto-corrected words added to its dictionary. It's nice to have autocorrect functionality, but just because of one wrong autocorrect, you don't have to reset the entire dictionary.


     
  16. campingsk8er macrumors 6502

    Joined:
    Feb 4, 2011
    Location:
    Elizabethtown, PA
    #16
    Just implement a rephrase so whenever it’s tyoed, it corrects to don’t
     
  17. user1239 macrumors newbie

    Joined:
    Apr 26, 2019
    #17
    After receiving a text from someone with the autocorrect, my phone started doing it. If you go to settings>keyboard>text replacement and add a shortcut to replace “dont” with “don’t” it fixed the issue for me. Probably not a fix for the actual issue, but it’s a work around.
     
  18. vlamb macrumors newbie

    Joined:
    Apr 30, 2019
    #18
    MY PHONE IS NOW DOING THIS. You’re not alone. My boyfriends phone start doing this a couple weeks ago and I thought he was lying. And we text every day. Now just yesterday, my phone autocorrected I don’t to “I.D.o.n.t” for the first time and has been doing this ever since. Maybe he infected me with this weird glitch.
     

Share This Page